1
$\begingroup$

I’ve done tracking of the footage, and I’ve setup the tracking scene. As you probably know, once you setup the tracking scene, Blender automatically creates two “Render Layers” nodes in the compositor. One node is for the “Foreground” layer, as shown in attached screenshot, and the other is for the “Background” layer. Also, Blender creates two collections in the outliner: foreground and background. Background consists only of “shadow catcher” plane.

enter image description here

The problem is, Blender is rendering separately those two layers / collections, which doubles my rendering time, and since I have very simple scene, that is in fact just a waste of time for me. I want to do all the rendering in a single pass.

I’ve tried deleting the background “render layers” node, and deleting the “background” collection, but still, when I try to render the scene, it always renders both foreground and background, although the background literally doesn’t exist anymore in my file. At least, I’m not aware of it.

I’m sure I’m missing some simple solution. Help!

$\endgroup$
1
  • $\begingroup$ I have the same issue. It is really annoying. I will post an answer if I run across anything. $\endgroup$ May 18, 2021 at 21:55

3 Answers 3

1
$\begingroup$

Have you tried going into the Render Properties > Film and ticked the box which says Transparent?

This will make the background of the render transparent so all you can see if the objects that you've added/created

$\endgroup$
2
  • $\begingroup$ Hi! Thanks, but that option has been turned on all the time and it doesn't affect the issue I have with the rendering. $\endgroup$ Feb 18, 2021 at 23:20
  • $\begingroup$ I guess being under "film" is as good of a place as any, didn't make sense to me, figured there'd be an option to hide the background from rendering under Camera or World Properties? So glad I found this answer, thank you! $\endgroup$ Aug 20, 2022 at 18:43
1
$\begingroup$

I had the exact same issue, and I couldn't find an answer anywhere. Here is what worked for me.

Go into Layer Properties in the righthand Properties panel. Then go into view layer and check Render Single Layer. This immediately solved the problem for me.

Check this box to have only one layer rendered.

$\endgroup$
1
$\begingroup$

It is at the very top right of your Blender window enter image description here Remove one of it to stop rendering two layers

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .