2
$\begingroup$

I’m encountering an issue and I am wondering if anyone could help me figure out why my created 3D model is displaying this way in 3D view. I have tried to use correct language where possible, but I apologize in advance if my terminology is lacking, as I am new to blender and 3D programs.

I am attempting to create an object which shows up as Shadeless in 3D view. However, although I have created and applied a material which is Shadeless, some faces appear to be affected by lighting in the scene. This only appears to apply to the faces on the back of the character's head, and the character’s legs.

Even when I turn off Shadeless in the material, the problem persists in those areas. However, if I turn off Textured Solid (under the Shading panel in the 3D view), the problem is not present, leading me to believe this is potentially some kind of issue with the material as opposed to the mesh.

I have already tried:

  • Removing doubles
  • Selecting all faces and recalculating normals

Other things which may be of note:

  • Although the legs are separated from the rest of the body by a UV mapping seam, this is notably not the case for the area on the head.
  • The entire model renders with shadeless: the shading issue only appears in 3D view.

Here is a link to the blender file.

This should clearly demonstrate the problem areas, on the legs and the back of the head. Even with shadeless deactivated in the material, the problem persists. When Textured Solid is turned off, the problem shading is not present, but (of course) the texture does not show in 3D view. the UV map, in case it is helpful in solving the issue.

$\endgroup$
2
$\begingroup$

There's a few things.

The normals of the faces in those sections are pointing in the opposite direction of the normals around it, but that's not the problem you describe, however it might be a problem later, best deal with it anyway. You can flip selected faces, if 'recalc normals' doesn't quite get all of them.

There seems to be a Vertex Color layer, with specifically those faces coloured. Press the minus on this. That will wipe the vertex colours.

enter image description here

How this happened? Being new to an application it is probable that you accidentally went into vertex paint mode a few times.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.