0
$\begingroup$

I'm having some trouble with a material.

While my project was created with an OpenGL normal map format, the export setting I used in Substance Painter was a DirectX-centric template. I've since made several manual edits to my texture maps in Photoshop. I've fixed this by inverting the green channel on the normal map using an RGB curve node in Blender.

A view of all of the nodes in this material.

Unfortunately, the problem persists. The model appears to have a certain shininess to it. This is only apparent in Blender, and not Substance Painter or Sketchfab.

Comparisons between Blender, Substance Painter, and Sketchfab

I've tried changing the normal map node from tangent space to object space, but that only seemed to have amplified the issue.

The object with its normal map node set to object space.

Does anyone know what's causing this? Thanks in advance!

Update: This doesn't appear to be an issue with the normal map, as it still happens even without anything plugged into the "Normal" part of the Principled BSDF node.

https://imgur.com/a/bYRKKgw

When I switch over to Cycles and change to rendered view, it works as it should, albeit appearing a bit more sharp.

The object displayed in Cycles.

$\endgroup$
2
$\begingroup$

Try converting your Normal Map using the method below, as opposed to using RGB Curves. As far as I know, this is the preferred method to do DX to OpenGL conversion. If it doesn't work, let me know and I'll delete this answer:

NormalConvert

$\endgroup$
6
  • $\begingroup$ Unfortunately, I'm getting the same results;; Even without a normal map, I have the same issue :< $\endgroup$ – MEATTAIL Feb 13 at 3:37
  • $\begingroup$ Even without a Normal map, you say. That is strange... Just as a longshot, try changing the IOR of the material - see what happens if you go slightly less than 1 $\endgroup$ – Christopher Bennett Feb 13 at 3:48
  • $\begingroup$ No luck with that either. I've tried changing the IOR to 0.75, 0.5, and later just slid it up and down. It doesn't appear to be changing the material at all. $\endgroup$ – MEATTAIL Feb 13 at 3:52
  • $\begingroup$ Very strange indeed. Have you checked your mesh in overlays to make sure the faces/normals are facing the right way? $\endgroup$ – Christopher Bennett Feb 13 at 3:54
  • $\begingroup$ Oh yeah, here's what it looks like with face orientation turned on. Also, I always leave backface culling on to ensure my normals are facing the right way. $\endgroup$ – MEATTAIL Feb 13 at 4:12
1
$\begingroup$

This is because of normals being too strong (I have thought it was reflection before too). Turn down the displacement node to about 0.1, or change to Cycles render and set the material displacement method from "bump mapping" to "displace" to see how strong it is working.

$\endgroup$
1
  • $\begingroup$ I changed my displacement node to 0.1, but that didn't make a difference unfortunately :< Also, iirc displacement/height maps only work in the Cycles render engine. I've changed to Cycles and the issue appears to be gone in render mode, no matter what the displacement node setting is. I'm not sure what you mean by setting the material displacement method, could you show me where I could set that? $\endgroup$ – MEATTAIL Feb 13 at 3:42
1
$\begingroup$

Check for custom normals data and clear it..

enter image description here

$\endgroup$
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.