0
$\begingroup$

I know this is a common question, but I looked through literally every single forum and I couldn´t fix it. I tried bumping the collision quality to 200, reducing and bringing up the collision distance, maxing out the impulse clamping... I need to deliver this soon and I´m out of options. Anyone? Edit: the only potential solution I could think of is slowing everything down and then bringing it back to normal speed so I get better collisions, but I´d rather not if possible. https://drive.google.com/file/d/1Y3LUKoXsWch-g_bTBJgH8Vmw-rqYKv4X/view?usp=sharing

$\endgroup$
6
  • $\begingroup$ Another tip could be to increase the collision distance for either your cloth or the collsion object. Tried that? $\endgroup$
    – DarkSoul
    Nov 14, 2021 at 22:32
  • $\begingroup$ Yeah, it says it right there. I tried bringing up and down both factors and it´s still clipping through. Thanks tho $\endgroup$ Nov 14, 2021 at 22:36
  • $\begingroup$ Sorry, didnt see that. You kinda tried most of the usual tricks I see. What exactlly are you rendering and at what point does it clip through? Have you tried changing other factors to see if it gives other results (random factors like stiffness, bending,etc?). When I used to bake clothin I would sometimes add a subsurface modifier to the collision object for better quality. Baking takes a lot more time though. $\endgroup$
    – DarkSoul
    Nov 14, 2021 at 22:58
  • $\begingroup$ That´s a good one. I added the subsurface to the cloth but never to the collision mesh. Lemme try that. $\endgroup$ Nov 14, 2021 at 23:02
  • 1
    $\begingroup$ Didn´t work. I´ll just post the blend and let sb else figure it out, cause I´m done. Thank you for your help $\endgroup$ Nov 14, 2021 at 23:14

1 Answer 1

3
$\begingroup$

I looked into your file and made several changes to make it work. It's not the best result, but at least it's not clipping. I haven't spend that much time, but if you invest some more, you can get better results. I have only been able to make the hoodie work for now. enter image description here

The reason why your arms clipped is because:

  1. Your clothing mesh is way too close to your body.If the clothes are closer than the collision distance, it wil clip through.
  2. Your armature stretches the clothing and because your cloth doesn't stretch with it, it clips through. Noticable when your character bends the arms.

How did I archieve this?

  • What I did at first was expand the size of your clothes so that there was enough room for the cloth to simulaye collision
  • Second I got rid of the hook modifiers of your cloth and instead used the rig to move the clothes.
  • I had to change the animation so the hands would go into the pockets without colliding with the body.
  • I used a shape key to expand your pocket and made it slowly shrink back to its original size so the hands would fit inside the pocket without issues.
  • I had to tweak several settings of your clothes to make it work.

Also: Quality steps were 20 and also 20 for collision. Collision distance set to 0,003m for both the collision object and clothing. I haven't used any subsurface modifiers. Baking was pretty fast for me.

My personal opinion It's really difficult to animate sleeves like that. I personally would archieved your goal slightly different. Cloth modifiers work perfectly when using very loose clothes, but gets complicated when trying to simulate tight clothes, especially during animations.

I hope this at least gives some hints and stuff. Here is the file.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .