1
$\begingroup$

Video: https://drive.google.com/file/d/1NJgEU3oITAyUqQu0f6W2y9treeCZ2Fhb/view?usp=sharing

I'm trying to make a parasol (outside umbrella thing) in blender, so I decided to use a cloth sim for the bit on top so that it would rest nicely on the top of the frame. The video shows you what is wrong. I created a plane and then used the knife tool to create 2 diagonal edges across the plane, and to create a vertex in the middle. I then moved the 4 outside vertices down. I set that plane to a cloth sim in the physics tab and the frame to a collision.

Quality steps: 20

Quality (collisions): 20

Enabled self collision.

Frame start and end 1 to 30. Top bit in edit mode Sorry for the low quality screen video.

Thanks for your time.

$\endgroup$
1
$\begingroup$

Firstly, 'Apply Scale' to each of your objects - this is important for any simulation.

Secondly, in your particular case you don't need to enable self-collision since the cloth isn't looking to be at risk of hitting itself. The self-collision will slow down the simulation and can cause its own problems if its parameters aren't appropriate.

Thirdly, 'Apply Scale' on your 'frame' objects and check the direct of the normals - you need to ensure they're pointing 'out' of the faces, not 'in' (otherwise the collision will be in the wrong direction). In your case the bars of the frame are quite thin - reduce the 'Inner' setting in the Soft Body And Cloth collision settings - you currently have it set to 0.200 and this is quite large for a "thin" structure such as this as it can result in the 'back face' affecting cloth at the opposite side of the bar.

Fourthly, ensure there are no overlapping meshes at the start of the simulation as this can cause significant problems as the simulation attempts to eject the vertices out of the collision mesh.

Don't forget to clear any baked simulation and re-run it to see if this helps. If this helps you can then start tweaking the simulation by re-enabling self collision (if needed) and potentially increase the 'Inner' and/or simulation quality. If this doesn't fix the problem, please post a video of the new behaviour.

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thanks for your speedy response! Video: link I have set the Inner setting in Soft Body and cloth collision settings to 0.05, made sure that all the normals are facing the correct way (the frame's weren't correct so I changed them), and that self-collision was turned off. I re-baked it and it seemed to look fine, but I was looking for more of a stretched fabric look to the top of the umbrella rather than a cloth just lying on top of it. Thanks very much @RichSedman $\endgroup$ – neptunestar999 Aug 7 at 6:26
  • $\begingroup$ @neptunestar999 There is still something going wrong with collision - you can see with the first movement of the cloth being to be dragged down to the supports.Try reducing Inner and Outer right down to the minimum and see if that changes. For stretching you need to have pinned your cloth (set up a Vertex Group and assign the vertices you want to pin to that group and then set the cloth pinning property to that group) - this lets you fix certain points. You can then stretch it by either moving those fixed points or having your cloth shrink as the simulation runs (animate Shrinking Factor). $\endgroup$ – Rich Sedman Aug 7 at 7:09
  • $\begingroup$ Thank you again @RichSedman. video I put Inner and Outer right down to 0.001, and I ran it again and seemed to be a little better, but when I assigned the vertex group for the four corners and enabled pinning, you can see what happens in the video. Thanks $\endgroup$ – neptunestar999 Aug 8 at 5:51
  • $\begingroup$ I think that's looking a lot better. Now try increasing your Cloth 'Quality Steps' setting (it defaults to 5). That sets how many calculations per frame are performed in the cloth simulation. Larger values result in smaller steps - increasing the chance of the collision preventing the cloth passing through surfaces. Don't increase way too far though as rounding problems can cause the simulation to become unstable. Also, you could try slightly increasing 'Inner' and/or 'Outer' - but change one thing at a time only and check the result and revert back if it makes things worse. $\endgroup$ – Rich Sedman Aug 8 at 7:34
  • $\begingroup$ Thanks again. I had already set the quality steps to 20, so I increased it again to 30. 1 2 3 $\endgroup$ – neptunestar999 Aug 9 at 8:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.