0
$\begingroup$

As the title says, I'm having a hard time rendering my particles in cycle (but they do appear in Eevee and viewport)

I checked the layer, the items visibility in render, the cameray ray, the emitter checkbox in the particle settings, and by all intent and purpose I think they should render? But they don't, so I obviously missed some setting, and I'm now pulling the "help me" card

https://www.dropbox.com/s/b0sh0ppfl08s7mk/WIP.blend?dl=0

Can anyone tell me what I've missed, please? Thanks in advance!

$\endgroup$
2
$\begingroup$

You use Emitter particles for your static particle crystals ("sprinkles"). For static particles that don't change their position like grass, trees, sprinkles, sesame seeds on a burger, ... it's better to use Hair particles. They are static and always dead.

Emitter particles are used for animation mainly. For birds, fishes, moths, dust, and fluid. They have a lifetime and die.

Looks like you knew that and have made the settings accordingly: Only 1 frame animation and set Frame Start and End to 1, lifetime 1. Unfortunately, it does not work because in frame 1 the particles are still unborn and not rendered by default. The nasty thing is that you see them in the viewport.

Possible fixes:

  • use particle type Hair. You need to apply the scale of the instance object and scale it up a bit. For some reason, the particles are smaller when rendered as Hair.
  • or set Frame Start and End to 0
  • or tick the checkbox Render > Extras > Unborn in particle settings
  • or render frame 2 and tick the checkbox Render > Extras > Dead in particle settings
  • or use particle type Hair ;-)
$\endgroup$
1
  • $\begingroup$ OMG thank you! That's going to be useful for so much more than this file too!!! $\endgroup$ Apr 14 at 17:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.