0
$\begingroup$

So I have an emitter object, emitting the said particles rendered from a collection. They show up in viewport shading with cycles, and when I render with motion blur, I see the motion blur for said particles. But the particles themselves, not a trace (they should remain scattered around after hitting the surface). I've been looking for ways to have them appear. All the collection is enabled for render, I tried baking the particle system before rendering, I tried rendering specific frames for tests and nothing. I've also set the start and end to 0, to a different value, tried particles as unborn, and as dead.. Just very basic falling particles.

The same particle collection is used as hair emission in another object (the proverbial donut), and they do show up in the render. Some images below with the particle system setup. I'm new to blender, and did what I could already for this very first animation, and before making this post. Any help is well appreciated.

collection layers particle setup rigid body 1 rigid body 2 collision for rigid body 2

$\endgroup$
4
  • $\begingroup$ Can you add a screenshot of your particle system settings? I suspect you may need to change the lifetime of the particles, but I can't tell without that information. $\endgroup$ Jul 15 at 17:00
  • $\begingroup$ Please provide blend file $\endgroup$
    – Chris
    Jul 15 at 17:04
  • 1
    $\begingroup$ @MartyFouts lifetime is 250. (see 3rd screenshot). -- I wonder why are the Emission settings grayed out? What is the render setting for the particles? (Render > Render As)? The default is "Halo" which means invisible in the final render. $\endgroup$
    – Blunder
    Jul 15 at 17:04
  • $\begingroup$ @Blunder the Render as is in the first screenshot. Trying to render as collection (as I did for hair particles). The blend file is here. And it gets grayed out when I bake it (forgot to add, but the blender version is 2.93) $\endgroup$
    – mg.Me
    Jul 15 at 21:21
0
$\begingroup$

It's the Motion Blur setting and probably a bug in Blender related to particles and motion blur. Baking as described in the bug report does not help.
Related BSE question from 2018 about the same problem but no solution: Motion blur still showing after particles hit a sticky plane

The particles are rendered but they are blurred because of the enabled Motion Blur. The particles fall down at high speed (within a few frames, that's a fraction of one second). The effect is the same as the blades of a rotating fan that become blurred and "invisible" as the speed increases.

That's correct when they are in the air: falling sprinkles
Falling sprinkles

But when the sprinkles land on the plate and stay there (they don't bounce in the viewport animation), they are still blurred because Blender probably thinks they still have a high speed. That's not correct:

sprinkles on the plate
Sprinkles on the plate (Motion Blur enabled)

It's weird because even when killed with the On Hit option and they stick like splinters in the plate they are rendered blurred.

When Motion Blur is turned off then you can see the particles clearly:

no motion blur
Sprinkles on the plate (Motion Blur disabled)

$\endgroup$
1
  • $\begingroup$ Ayy, it worked! Thank you! I'll try messing with the motion blur now to see if there's a way to deactivate it after the particles die. I f it's not possible, at least now I feel I can move on to render more complex stuff. Thanks again! $\endgroup$
    – mg.Me
    Jul 17 at 0:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.