1
$\begingroup$

What I did

I made like this desk with mat by using cloth simulation enter image description here

Problem

When I use cycles, looks like that through glass enter image description here

And Evee looks like that. Desk mat doesnt show, and I realized under tap is not shown as well just now(it's image texture). enter image description here

This is glass shader enter image description here Somebody knows how fix it??

*add 1

I changed material settings of desk mat like this pic ↓ enter image description here

and result is like that, as you can see desk mat appears!
(I still doubt its proper setting cuz according to your sources which pasted, alpha blend is proper setting)
so I changed material settings of place under tap as well, the same as desk mat. but unfortunately it shows only frame.enter image description here

$\endgroup$
4
  • $\begingroup$ Is there any transparency or transmission in the cloth materials? Transmission/glass doesn't layer in eevee, see blender.stackexchange.com/questions/193443/…. If its not transmission but alpha transparency, you need to set the appropriate blend modes on both materials. Also useful is blender.stackexchange.com/questions/189716/… $\endgroup$
    – Sazerac
    Sep 29 '20 at 1:05
  • $\begingroup$ thanks for answering :) I added "*add1". tried to change material settings. desk mat appears, but place under tap still hides(image texture) $\endgroup$
    – kazon
    Sep 29 '20 at 11:03
  • $\begingroup$ check all the visibility settings on the bit under the tap? Opaque for blend mode is the correct setting for non-transparent objects, and either alpha blend or alpha hash are generally the way to go for transparent objects, more info: docs.blender.org/manual/en/latest/render/eevee/materials/… $\endgroup$
    – Sazerac
    Sep 30 '20 at 0:26
  • $\begingroup$ omg, I realized under tip place has two materials, and I forgot fixing one of them. Now I set "oppaque" and everything appears through glass in Evee. thank you!! $\endgroup$
    – kazon
    Sep 30 '20 at 0:33
1
$\begingroup$

change material settings
blend mode: opaque
shadow mode: opaque
screen space refraction: no

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.