1
$\begingroup$

I don't see my fluid inside the glass, but i can see the object inside the glass. Does somebody know, what i have to change, to see fluids through glass?

Or is this not possible in Eevee? Can i fake it somehow?enter image description here

$\endgroup$
1
  • $\begingroup$ Hi there : ) .Can you add an image showing the node setup of both the glass and water material . It's always important when it comes to questions regarding shading. Its leterally impossible to know whats happening without it. $\endgroup$
    – Nxdhin2005
    Aug 3 '20 at 8:49
1
$\begingroup$

If you use the Glass node you need to enable the following options :

  • Render panel > Screen Space Reflection
  • Material panel > Settings > Blend Mode > Alpha Blend
  • Material panel > Settings > Screen Space Refraction

There is a limitation for the moment in Eevee: You can't see an object that is in Blende Mode > Alpha Blend through an object that has a Glass material, as you can see here, object 2 is not visible:

enter image description here

If you give object 1 a bit of transparency and therefore decrease its Glass value, you kind of get around the problem (you can also get rid of the Glass node and find another way to simulate glass, like a mix bewteen Glossy and Transparent):

enter image description here

$\endgroup$
1
  • $\begingroup$ Thanks! This helps. I didn't activate the Alpha Blend for the Fluid. Now with alpha blend everything is fine. $\endgroup$
    – Viranto
    Aug 3 '20 at 16:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.