5
$\begingroup$

New to blender, got a question about window glass.

I have tried several examples but can't get it to do what I want.

The problem is that the background which I have set in the world settings is getting blurred when viewed through the glass material.

I have attached a screenshot. The selected object is a plane to which I have assigned the glass material. As you can see the background through the plane is being blurred.

I have no idea which setting is getting me this effect. I have tried a lot of sliders :-)

Hopefully someone can shed some light on this.

screenshot

Edit:

I tried using IOR 1.0. Still the same issue. Although when rendered with cycles (which I don't use on osx) the blur was gone.

So it seems to be an Eevee setting or issue.

Any idea what can affect this in Eevee?

$\endgroup$
1
  • $\begingroup$ It might be caused by the glass pane's refracting of the background; acting as a sort of lens, it "zooms in" on the image, making it look low-res. You can check this by setting the material's IOR to 1.0 and seeing if the problem persists. $\endgroup$
    – impresso
    Apr 9 '20 at 1:43
4
+50
$\begingroup$

The refraction algorithms in Eevee (which the glass shader uses either) lower resolution of everything behind refracted surface to speed up render and performance - this is what causes the bluriness. If you don't need a refraction distortion, the solution as it has been already mentioned is in using Principled BSDF. Increase "Metallic" all the way up to 1 and plug in Fresnel node into Alpha socket - you will get a fake glass material without lowering a background resolution. Anyway if you need a physically correct refraction I'm afraid the only way is to use Cycles.

$\endgroup$
1
  • $\begingroup$ This is it. Glad to know where the blur comes from. $\endgroup$
    – McDJ
    Apr 9 '20 at 15:06
3
$\begingroup$

If you want to create a window, it's usually best to leave the glass out. Otherwise you will create a noisetrap inside. If the window is not the main focus of the scene, it will not be visible that you didn't put in glass panes. If you really need a window, use a Principled BSDF shader. It is more general and can do more things than a glass shader, but a glass shader will work fine as well. If you need the window to not blur the scene, set the IOR (index of refraction) and of course the transmission to 1. That's the value for a vacuum.

$\endgroup$
3
$\begingroup$

Render Properties

  • Turn on Screen Space Reflection as well as its Refraction now for the material setup;

Shader Setup

  • Use a Principled BSDF shader and increase Transmission to 1, change the Transmission IOR to 1, and decrease the Roughness to 0 else you get a frosted glass.
  • Under settings activate Back Face Culling, change Blend Mode to Alpha Blend and Shadow Mode to None.
  • Activate the Screen Space Refraction and change the Refraction Depth to 0.65 or any other input rather than the default 0.

NB: I'm dealing with two different screenspace refractions; That of the render properties and the other one for the material properties which comes just after the volume sub drop menu.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.