0
$\begingroup$

Blender version: 2.82rc, 2.83alpha.

I am trying to set up eevee to properly show reflections on my glass material.

The glass object is an uv sphere, which I cut in half and then applied solidify modifier, so that it became a hollow semisphere.

When i render in cycles i can see the proper reflection of the purple monkey head:

cycles-correct-reflection

But when i render using eevee, there is no reflection of the monkey or the floor plane:

eevee-lacks-reflections

In eevee i have tried to add spherical reflection cubemap around my glass object, but it did not help:

reflection cubemap settings

The eevee screen space reflections settings i tried:

screen space reflections settings

And indirect lighting settings:

indirect ligting settings

My glass material uses simple transmissive principal bsdf shader:

glass material nodes

Is there any way to make eevee reflections closer to the cycles result? Is it possible to see the other objects properly reflected? The blend file i used: https://drive.google.com/file/d/1rljUoxhp4Ajbm7JIjpGwjlmQCButQ3BR/view?usp=sharing

$\endgroup$
1
$\begingroup$

have you checked that the clip distance is correct in the reflection cubemap? "Clipping Start" should be slightly larger than the size of your object (the glass sphere) and Suzanne must be between clipping start and clipping end. I suggest to activate "Clipping" in "Viewport Display" in Reflection Cubemap settings as in next image:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ Thank you! That resolved the issue with missing reflection. But now i see a weird extra reflection of the floor with a hole in it: i.imgur.com/jDByQGD.png Does it look like eevee limitation or could it be prevented with some setting? $\endgroup$ – user920391 Jan 27 at 17:45
  • $\begingroup$ yes it is weird, but there is not enough information to understand what originates the problem, I don't think it is due to an Eevee limitation. $\endgroup$ – joaulo Jan 27 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.