0
$\begingroup$

Using Eevee, I'm trying to simulate a light bulb. I have a sphere with glass material and inside it, I have a Point light. But the light is not passing through the glass:

enter image description here

However, if I disable the sphere object, the light is working:

enter image description here enter image description here

How to make the light inside a bulb lamp pass through glass (using Eevee)?

Here my test project:

$\endgroup$

1 Answer 1

3
$\begingroup$

Changing shadow mode from opaque to None will allow your light to pass through. And changing blend mode from alpha clip to alpha hashed will give you a more realistic looking glass. Enable screen space reflection too in render tab

Also, change your shader material to this: enter image description here

$\endgroup$
4
  • $\begingroup$ Thanks, but you see that the sphere is being rendered with flat faces, even with Shade Smooth activated for it. How to solve this? $\endgroup$ Dec 7, 2020 at 14:30
  • $\begingroup$ @RogérioDec it doesn't for me try adding a subdivision modifier $\endgroup$
    – JacksonPro
    Dec 7, 2020 at 14:51
  • $\begingroup$ Tks, but if you look into your own image you'll see that the sphere is being rendered in a not smooth shading, you clearly can see the faces and edges... the sphere should be smooth... $\endgroup$ Dec 7, 2020 at 15:30
  • $\begingroup$ @RogérioDec that's because I didn't give shade smooth $\endgroup$
    – JacksonPro
    Dec 7, 2020 at 15:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .