4
$\begingroup$

I am trying to simulate a wedding dress animation.

So I put a solidify modifier on the dress, and I defined the dress as a cloth.

  • The lower part is free (pinning of the upper part).

  • I unchecked "Cloth collision" for the dress, but I added collision physics to it.

  • I also added collision physics to the character wearing the dress.

My problem is that the dress still goes through the character.

Why is that the case?

Here is how it looks: - before animation:

enter image description here

  • after 4 frames of animation:

enter image description here

And finally, may you please see here the settings of the dress :

enter image description here

enter image description here

When I loaded these pictures, as you can see, I finally checked "cloth collision", which is different from what I said at the beginning of this topic. It is because I took into account the PGmath's comment.

Here you can find the Blend file: it is already animated.

$\endgroup$
  • 1
    $\begingroup$ Why did you uncheck cloth collision? $\endgroup$ – someonewithpc Jan 4 '16 at 23:06
  • $\begingroup$ Hello, I read that on the internet. $\endgroup$ – babox Jan 4 '16 at 23:07
  • $\begingroup$ The dynamic of the dress is much nicer that way $\endgroup$ – babox Jan 4 '16 at 23:07
  • $\begingroup$ You can't keep the cloth from going through the character without enabling collision on the cloth sim. Enabling collision physics allows other objects to collide with the cloth, it does not affect the simulation. $\endgroup$ – PGmath Jan 5 '16 at 3:18
  • $\begingroup$ you should move the solidify modifier under the cloth simulation , the problem seams to be in the cloth itself ( not cloth& body ) $\endgroup$ – Chebhou Jan 5 '16 at 19:29
5
$\begingroup$

In order to keep the cloth from going through other objects you need to enable Cloth Collision. Cloth collision allows other objects to influence the calculation of the cloth simulation. (Adding the Collision physics type only allows other objects and particles to collide with the cloth, it does not influence the cloth simulation of the object on which it is enabled.)

When Cloth Collision is enabled, the cloth simulation will collide with all objects which have the Collision physics type enabled. So in your case, you should enable Cloth Collision in the cloth sim settings and enable Collision physics on the character.

Cloth Collision settings

To get a decent looking simulation you will have to play around with the collision settings. Here are a few key things to adjust:

  • Quality is basically the number of steps blender takes to simulate the cloth, higher quality = more steps = longer baking time = better looking simulation. I rarely find the default quality of 2 to be decent, I often use between 3 and 5.
  • Distance is essentially the "thickness" of the cloth, the threshold of how far away from the cloth mesh a collision is registered. This is important because, due to the geometric nature of a mesh, there will always be intersections between two colliding objects. By increasing this you can move the collisions away from the actual geometry slightly, minimizing actual geometric intersections.
  • Friction is how "sticky" the cloth is, how much it resists being dragged against another surface. If your cloth has too much friction it will stick to the character unnaturally as it deforms, too little friction and it will appear unrealistically silky.
  • Self Collision allows the cloth to collide with itself. Enable this if the cloth mesh is intersecting and going through itself too much. Self Collision has its own Quality and Distance values for better control. This will drastically increase baking times too, so beware!
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.