3
$\begingroup$

I am following a beginner tutorial on Blender Guru’s YouTube channel.

I am creating a glass cup with liquid inside, and I am using the Volume Absorption settings on the Material panel in order to create the desired effect on the liquid.

As far as I know, I’ve followed the tutorial exactly, but as you can see from the attached image. There is some odd yellow/gold band as the top front of the liquid.

Normally, I would experiment with different settings, but as a complete beginner, I don’t really know where to go and what to adjust. With my extremely limited experience, I think it is something to do with reflections, as it looks like there is something else going on with that area, but I haven’t really got a clue.

Can someone please point me in the right direction?

Thanks.

Picture of cup with coffee inside. There is a weird yellow/gold band at the top of the liquid

$\endgroup$
8
  • $\begingroup$ Hello :). Could this be a reflection from an HDRI? blender.stackexchange.com/q/170533/78972 $\endgroup$ – Jachym Michal Jul 14 '20 at 17:11
  • $\begingroup$ That’s what I was thinking, although I didn’t know what it was called. I will certainly give that a try. Am I able to set it to something generic that wouldn’t give me those reflections? Also, how would I do that? Thanks. $\endgroup$ – Gareth Lewis Jul 14 '20 at 17:28
  • $\begingroup$ Follown the link, it's all explained there :). $\endgroup$ – Jachym Michal Jul 14 '20 at 17:31
  • $\begingroup$ Thanks Jachym. Ok, I am reeeally beginner so I’m not sure where all the options are :) I’ll try it out later and see if I can get through it. $\endgroup$ – Gareth Lewis Jul 14 '20 at 17:41
  • 1
    $\begingroup$ It is because the liquid overlapping with the glass. If you are talking about the yellow looking area. This happened to me too. $\endgroup$ – BlenderNueva Jul 14 '20 at 18:11
1
$\begingroup$

I think I managed to fix it. After experimenting with the scale of the liquid and HDRI and shading settings, I found out it was neither of these.

I hid the liquid by using the eye icon while in render view and I noticed the line was still there, and when I switched to object view, it still looked like there was a still a liquid shape. What I think I did was duplicate the vertices and right clicked rather than make a separate object. I then created a new liquid layer on top.

So what I did was click on the cup in Edit Mode and then Merge Vertices > By Distance. This effectively removed that additional liquid layer I had in the cup object.

Fixed!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.