2
$\begingroup$

Recently, I've been trying to make a donut and coffee using blender guru's tutorial. However, earlier today, I made a change (though I'm not sure what exactly), which caused my glass material to act very strangely. It now distorts everything behind it in an odd way, has very large black bars on the edges and the fluid behind it cannot be seen it all. It's also casting a shadow, which seems odd. I don't know what settings I changed, nor do I even know the nature of the problem. I've tried increasing light paths to the maximum, but that just makes the bars on the side turn gray. I was playing around with the cycles render settings earlier, as I couldn't figure out why it wasn't working in the viewport (It was simply paused) If anybody has advice or a fix, that would be much appreciated. I'm an absolute beginner to blender, and would rather avoid scrapping my first ever project (Though more due to time than sentimental value).

enter image description here enter image description here enter image description here

$\endgroup$
5
  • 1
    $\begingroup$ The only thing that comes to mind: Go into edit mode, select everything Press SHIFT N, see if the error persists. Did it render differently before? If so show your Scene Tab, specifically the Light Path Settings. $\endgroup$ Commented Mar 27, 2020 at 19:28
  • 1
    $\begingroup$ I hit [Shift] + [N], but to no avail. I'll post another photo with my light path settings, but changing them has done very little thus far. $\endgroup$ Commented Mar 27, 2020 at 19:33
  • 2
    $\begingroup$ Unless you have access to 8 Titan GPUs with crossfire, I would suggest taking these values down to 12. If you're super-crazy for accuracy maybe go up to 128 the very most. Also someone correct me if I'm wrong, but I think that's how glass works in the real world as well. Try an HDRi BG and see if it feels more "real" when there is something to reflect. $\endgroup$ Commented Mar 27, 2020 at 21:23
  • 1
    $\begingroup$ Yep, I have them at their default settings normally. I just cranked them up to max to eliminate the possibility of that being the issue. $\endgroup$ Commented Mar 27, 2020 at 22:36
  • 1
    $\begingroup$ Verify your normals. Is the object totally closed? check the IOR (index of refraction) value in your node setup ( should be around 1.4). Can you add a screenshot of your shader nodes? $\endgroup$
    – Bruno
    Commented Mar 27, 2020 at 22:46

1 Answer 1

1
$\begingroup$

Make your cup, go into Edit Mode with Tab, press A to mark all lines.

On the top left behind the Edit Mode line in the menu Mesh > Normals Flip. The whole ⇧ Shift + N shortcut did not flip for me.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .