5
$\begingroup$

What I’m trying to achieve is an glassy object. Therefore I’ve opened a new scene in Blender 2.82a. I’ve Enabled Screen Space Reflections in Render Properties and set “Shade Smooth” for the object. I’ve set Transmisson to 1, reduced Roughness to 0 and enabled Screen Space Refraction in Material Properties. I didn’t do anything else. Entering the Viewport Shading view I’m seeing this:

Why is my glass cube showing trees?

I’m afraid this is as newbie as it gets, but I’m stuck. I’ve dived into various settings for an hour or so and I’ve tried to google a solution for another without having any luck because I’ve no idea what’s happening and why. Why are there trees reflecting in my glass cube in an otherwise empty scene? And how do I get rid of them? I’ve found a place where I can change the image by clicking on the upper right downwards pointing arrow. But I’m unable to remove it or to replace it with a plain color or whatever. I’ve tried to enable ”Scene Lights“ and ”Scene World“ but that’s turning everything into anthracite leaving me literally groping in the dark.

$\endgroup$
2
  • 2
    $\begingroup$ You probably don't want "Shade Smooth." It has nothing to do with whether the surface of your object is smooth(glossy) as opposed to rough. Shade Smooth averages the surface normal vectors over your mesh. In effect, when shade smooth is on, light interacts with the cube as if it were a sphere. $\endgroup$
    – Rekov
    Jun 22 '20 at 17:10
  • $\begingroup$ What exactly did you expect to see when you remove this image? The only thing you see when looking at a perfectly reflecting/refracting object is the surroundings. $\endgroup$
    – pipe
    Jun 23 '20 at 3:52
7
$\begingroup$

The screen space reflections in Eevee especially with highly reflective materials, for example metal with 0 roughness or glass like yours, will always show the environment like a mirror.

In Material Preview (Eevee is used, even if Cycles is set as render engine), you have a few HDRIs to choose from and if no Background is set up manually, Blender will use it's preinstalled HDRIs.

enter image description here
The default one used is the 3rd one.

Those are only for convenience and not necessarily used for final results. Also the place where you set your own world environment, be it a color or HDRI, is in the World Properties:
enter image description here

The easiest way to set up your own HDRI, is to go in the Shading tab and do the following:

  1. Switch the mode to World
    enter image description here
  2. In the Shader Editor press Shift+A to add a new Environment Texture Node.
    enter image description here
  3. Connect the Color output of the new Node to the Color input of the Background Node.
  4. Now you can load a HDRI in the new node. You can find free HDRIs online (HDRIHaven for example). Beware though, they are rather big files if you want good resolution.
  5. Lastly if you have an HDRI loaded in, you want to turn the Scene World option in the Preview Mode on, so it will use your HDRI and not the default one anymore.

Here how it can look:
enter image description here
mind that i did not set the cube to glass

In case you just want a color, skip all the steps and directly in the World Properties the color field above the Strength can be used to change and adjust the color used for your scene. I'd advice though against using the pure color, as it really is nothing else then making the entire scene be in that one color.

Here how that can look:
enter image description here

There are a lot tutorials out there, worth watching, as there are so many features, that it can be overwhelming at the start.

Happy Blending

$\endgroup$
3
$\begingroup$

The preview you are in is called lookdev, which generates lights and reflections from a hidden HDRI image. If you want to see your model how it would look rendered, switch to rendered preview.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.