1
$\begingroup$

PROBLEM

Hi! I chroma keyed a green screen video in DaVinci Resolve, then imported it with Image As Plane into a blender scene as an Emission node so it’s not affected by lights in the scene (I just change emission strength to match the scene).

In DaVinci, the key is fine, and there is no weird dark outline. But when imported into Blender, it looks like the following:

Weird dark outline on keyed blender object

And here's the node tree:

node tree of this problem

Why is this happening, and how can I fix it? The only thing I can think of is that there’s something wrong with the codec I used to export the keyed video from DaVinci, or something’s up with Blender.

And for all this:

  • I’m using Blender 2.93, and cycles.
  • I set the video’s Material Properties → Viewport Dispaly → Settings → Blend and shadow modes both to Alpha Clip.
  • I turned the light paths max bounces all the way up to 5+ for everything. Even though there’s nothing that would get in the way to prevent light from passing through, etc
  • I set Light paths → Clamping both to 0.
  • I set the alpha in my video’s node in the Shading tab’s N-panel to both Straight, and Premultiplied.
  • I messed with every material setting that had a positive value, and it changes nothing.
  • In DaVinci, I used the GoPro CineForm RGB-16 bit codec with Alpha export on, and that’s the only codec with an alpha channel available for me on this computer, so I can’t test other options.

Thanks!

$\endgroup$
2
  • $\begingroup$ Could you add a screenshot of the node tree? $\endgroup$
    – HISEROD
    Dec 12, 2021 at 21:56
  • $\begingroup$ Just added it, and thanks for helping btw. $\endgroup$ Dec 12, 2021 at 22:01

1 Answer 1

0
$\begingroup$

Just fixed it. The problem was my original key.

Originally, I never tested the key against a white background. It was always either transparent or black. Thus, I never saw the dark outline.

Then I fixed the key, imported it into blender, and it worked perfect.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.