2
$\begingroup$

I am having an issue with a rendered animation not showing all the parts of all the components. Some parts of some of the objects flicker in and out of existence. The animation video can be found here: http://youtu.be/R0ohe7N5rmQ I have made this with 2.71 and cycles. How do I stop the flickering issue? The blend file can be downloaded here: http://www.pasteall.org/blend/32356

I have made an animation of objects (carbon nanotubes) being ejected from a tube. I want to the tubes to land on the substrate through shadow mask, and stick there. Then I pull of the mask to reveal some rectangular collections of tubes.

Any help would be much appreciated!

Edit: Removed second question: "Also, if anyone has a good idea of how to speed up the animation, especially concerning the treatment of the particle object."

EDIT 2: The expanded camera limits did not fix my problem, as I have now figured out. I have changed the animation around a bit with the new blend file here: http://www.pasteall.org/blend/32448 For example, in frame 100, if I have the "emission circle" visible in the render, I can see only half of some of my other objects and some of the objects disappear completely. If I turn off the visibility of the "emission circle" I can see those objects again. I tried reducing the number of particles being emitted. I show here two screenshots with and without the particle emitting object visible. Doe anyone have a recommendation?

All objects visible when particle emitting system is not visible. Part of objects no longer visible when particle emitting system is visible.

$\endgroup$
  • $\begingroup$ Your post has many questions, please split them in different posts, it makes it easier for futures searches and to keep the site organized. $\endgroup$ – cegaton Oct 25 '14 at 21:02
  • $\begingroup$ @cegaton, Will do. $\endgroup$ – PhDeadlift Oct 26 '14 at 16:55
3
$\begingroup$

The objects appearing and disappearing is a problem with the clipping distance of the camera. Select the camera and make the clipping start distance much smaller.

enter image description here

$\endgroup$
  • $\begingroup$ This seemed to work. I went through the scene and did not encounter any major issues with the start clipping too far from the camera. Before I changed it I did a quick render with only 3 samples, and it did not have the same flickering problem. So, I don't know if the clipping is the only thing wrong with my render, but it seems to work. Thanks! If I can figure out what else is wrong with my flickering problem, I will post the fix. $\endgroup$ – PhDeadlift Oct 25 '14 at 21:58
  • $\begingroup$ @PhDeadlift Also please do edit your question and split it into more posts. $\endgroup$ – cegaton Oct 25 '14 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.