1
$\begingroup$

This boolean object appears when I render. I turned off the render and view option in the outliner but it still appears.

Please help! Thanks!

enter image description here

I tried turning off all the render and visible keyframing in the outliner, but I still get the same problem. Here is the before and after, 1st is render view and 2nd is the actual render result.

enter image description here

enter image description here

The boolean object that keeps appearing is used to hide the paper halfs, so there are no shredded papers revealed before the shredding machine, and no unshredded paper revealed after the shredding machine. Here is the result before I render below.

enter image description here

I get this "mask" result when I render it out, but in some parts of the animation that cube will show up. I checked my keyframe timeline and there are not keyframes near where the mask will randomly appear.

This is what i'm trying to achieve! But the boolean object keeps appearing in my render. enter image description here

$\endgroup$
  • $\begingroup$ Have you Applied the Modifier? $\endgroup$ – Dontwalk Dec 1 '17 at 17:03
  • $\begingroup$ Hey thanks for replying! I'm animating the position of the object that has the boolean on it, so I don't want to apply the modifier. I want the object to be revealed as it moves out of the way of the modifier. $\endgroup$ – Thad Dec 1 '17 at 17:05
  • $\begingroup$ @ Thad - I dont have time to test it out but I know the object won't be deleted if you apply the Boolean Modifier. It will still be there allowing you to animate. You may want to Apply Scale to both objects before applying the Modifier. $\endgroup$ – Dontwalk Dec 1 '17 at 17:13
  • $\begingroup$ Selected object on the screenshot has Boolean modifier added and has its Render option in the Outliner enabled and keyframed which means it might change in the animation. Check if there is anywhere keyframe for the object to be renderable. $\endgroup$ – Mr Zak Dec 1 '17 at 17:25
  • $\begingroup$ Hmm I turned off removed those keyframes, but I still get the same results. I'm trying to look at if I can use a mask in layers instead of boolean right now. $\endgroup$ – Thad Dec 1 '17 at 17:33
0
$\begingroup$

Finally found what was wrong.

I was using the "mask" object for 2 different boolean modifiers. I created a separate object for each boolean modifier and it rendered correctly.

Thanks for all your help!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.