1
$\begingroup$

So even though I am not planning on using a Glass shader for the ground, I noticed that only objects that have Emission shaders attached are reflecting off the ground even though the Diffuse lit objects have the same level of brightness.

Basically everything that has a Diffuse shader shows up completely black. I've outlined these areas in the image that I've attached.

It does seem somewhat logical that an emission shader would show up brighter in reflections but since the brightness is the same as the Diffuse lit objects it also seems very strange.

So is there a way to get the Diffuse lit objects to show up in reflections just as the Emission lit objects do?

enter image description here

enter image description here

Here's the .blend ~1.5MB http://www.pasteall.org/blend/30054

I've checked the Ray Visibility and everything is activated.

$\endgroup$
1
$\begingroup$

Update

After checking your .blend, it appears this is because you have your bounces turned way down in Render settings > Light paths.

Increase the maximum allowed glossy bounces a bit (at least 1), and it works as expected:

enter image description here


Original answer

If it is ray visibility as GiantCowFilms suggested, I would think it's more likely to be disabled Glossy rays on the diffuse objects.

Because of the backwards nature of the way cycles traces rays, reflections on an object aren't directly influenced by that objects ray visibility.

For example, given a simple scene like this:

enter image description here

If the glossy ground plane is invisible to diffuse rays, it still will render with reflections of diffuse objects. Removing the diffuse ray makes the diffuse object no longer affected by indirect lighting from the glossy plane (a very subtle change).

enter image description here

However if you make the diffuse object invisible to glossy rays, the ground plane will not reflect the diffuse object (in this case, it will reflect sky instead):

enter image description here

$\endgroup$
  • $\begingroup$ This does not appear to be the issue but it's still helpful $\endgroup$ – MarcClintDion Jun 27 '14 at 17:46
  • $\begingroup$ @MarcClintDion Updated $\endgroup$ – gandalf3 Jun 27 '14 at 18:42
  • $\begingroup$ This is a forehead slap moment. Doh! I set it low since I mostly bake diffuse and the start-up file has those low values as default. Thanks again. $\endgroup$ – MarcClintDion Jun 27 '14 at 18:59
1
$\begingroup$

Probable Cause:

Your ground plane has Incorrect ray visibility settings In order to check if this is the issue, select your ground plane and diffuse objects. and make sure all the settings look like this: enter image description here

If they don't, change them.

Also note that a Light path node could be the culprit as well.

$\endgroup$
  • $\begingroup$ Did you mean the Light path node? $\endgroup$ – gandalf3 Jun 26 '14 at 20:27
  • $\begingroup$ There is no lightPath node but thanks for the reminder to check the Ray Visibility when trying to diagnose problems. $\endgroup$ – MarcClintDion Jun 27 '14 at 17:45
  • $\begingroup$ @MarcClintDion, I was just trying to write every possible cause for your problem I could think of, since when I wrote it you hadn't uploaded your .blend. $\endgroup$ – GiantCowFilms Jun 27 '14 at 20:20
  • 1
    $\begingroup$ no problem, I appreciate that you were trying to help. If my response came across as anything other than this, then I apologize. $\endgroup$ – MarcClintDion Jun 27 '14 at 20:48
  • $\begingroup$ @MarcClintDion no worries! $\endgroup$ – GiantCowFilms Jun 27 '14 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.