What phenomenon is causing this waffle-patterning in this transparent texture? I want to research what is happening, but don't know what direction to go.

Originally, I started off using a principled shader, but even the plain sss shader is exhibiting this.

Can I add a blend file to these questions?



Here's the blend file:

this was the pbr shader, with the Christensen-Burley surface method. It took a long time to render, compared to the random walk one with the plain SSS really long render time with pbr shader

Plain SSS comparitively short render time in plain SSS

I added the level 1 modifier, but these artifacts are still visible still visible artifacts after a subdivision mod

Here's the node tree that I ended up going with, after taking the subdivision modifier back off of the mesh. The influences of the SSS in the shader seem to be negligible, and I'm happy with the result-- wasn't going for physical accuracy.

Hopefully, this helps someone out there crude-oil node tree

  • $\begingroup$ Yes you can use Blend-Exchange to add your file. You need the address of your question and later just copy and paste the generated link in your question. $\endgroup$
    – Xylvier
    Mar 24 '20 at 3:29
  • 1
    $\begingroup$ Duplicated geometry, perhaps? Check there isn’t a duplicate of your mesh or that there aren’t duplicated faces within your mesh. $\endgroup$ Mar 24 '20 at 7:38
  • $\begingroup$ try connecting Principled BSDF "BSDF" output to Material Output "Surface" input? $\endgroup$ Mar 24 '20 at 11:38
  • $\begingroup$ That's really interesting. Does it only occur with random walk? Does the patter represent your topology, or do the waffles occur randomly? Have you removed doubles? $\endgroup$ Mar 24 '20 at 23:00
  • $\begingroup$ @Xylvier --Thank you, the blend file is here now, so we can all compare apples to apples $\endgroup$ Mar 25 '20 at 18:38

I believe it's the fact that the resolution of the mesh is so low that the angles from face to face are so sharp that the SSS sees it as a corner that is thinner and thus lightens it up (expected from SSS, but rather extreme). The sharper the corner the brighter. As soon as i added a lvl 1 subsurface modifier, it made the surface smooth enough geometry wise to calculate the surface as if it was one rounded shape.

The fact that if you change the shading to Flat Shading the brighter lines along the sharp folds of the faces becomes even more pronounced makes me sure that SSS really only gives that result because on the low resolution surface.

Here a comparison with a quadsphere with just one point dragged out to create an extreme that the SSS instantly shades as it did in the file shared. enter image description here
Also visible here is that the quads seem to be internally triangulated and the resulting edges are generating the thinner corners or folds which get calculated by the SSS algorithm. Specifically the "Volumetric" version used in Random Walk as that is a volumetric approximation of a physically based volume scattering.

While it was not asked for a solution, i would still think that a level 1 subdivision modifier should get rid of the pattern.

enter image description here

This result i got from rendering with 128 samples at full resulution and only lvl 1 subdivision surface modifier. I had to remove the background and replace with a color, as the image was missing. Also due to the camera setup being a bit stubborn, i deleted it and created a new one for a simple close up. If you did not use anything on the camera.

enter image description here

This is with the adjusted Principled BSDF shader.

  • $\begingroup$ thanks for looking at this. I posted a rendering of the PBR shader that took an extremely long time in my opinion compared to the plain SSS one (maybe because of the CPU render). I'll try a render with a subdivision modifier put on it, and see if that helps $\endgroup$ Mar 25 '20 at 22:19
  • $\begingroup$ I edited the question with the subdivided render using the plain SSS with Random walk. Almost seems like I need to edit a samples number or a volume number somewhere in the file to make it better. With a ton of subdivision, this may look like I want it to, but I'm concerned with the render time difference that something is messed up in my file somewhere. This solution could work for me, but it seems like it's a remedy to a symptom of a larger problem. Would this be called "sub surface artifacts"? $\endgroup$ Mar 25 '20 at 22:39
  • $\begingroup$ I updated the answer to show the settings and result with my adjustments. Hope that helps. $\endgroup$
    – Xylvier
    Mar 25 '20 at 23:12
  • $\begingroup$ I don't normally adjust the auto smoothing on the normals, but toggling that on helped a bit. $\endgroup$ Mar 26 '20 at 22:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.