1
$\begingroup$

I am trying to get alpha leaves in a tree from an older file to work.

All the tutorials say got to Material > Otions > Blend mode. And switch the Material's Blend mode to something other than Opaque.

My problem is that my material options look nothing like any of the tutorials suggest, and I get no Blend option to get my alphas working.

Below is a picture of my shader nodes and what my options look like.

NOTE: when I create the material in a fresh scene I do get the Blend option. But any material I create in my current scene just looks like the screen shot below. Is there something I can do to fix my scene ? I'd hate to have to recreate this scene from scratch just to get this working.

enter image description here

$\endgroup$
1
$\begingroup$

Your screen looks like you have set Cycles as Render Engine not Eevee.

When you switch to Eevee render engine in Render Properties Editor ...

enter image description here

... than you will have available Blend mode from properties panel

(Shader Editor > Properties > Options)

enter image description here

Also availaible from Material Properties Editor > Settings > Blend Mode

enter image description here

$\endgroup$
  • $\begingroup$ As the OP is asking specifically about Eevee so looks like they don't know to vlivk on the materials tab in the props area rather than looking in the shadin workspace node editor $\endgroup$ – Moog Nov 3 at 19:41
0
$\begingroup$

Found a workaround: I should have added that my objects are linked into my scene. I didn't think the render setting of a linked object's scene mattered, that only the render setting of the final scene did. In any case, going back to my original objects, I created a new alpha material by importing the image as a plane (using the add-on). This gave me a new shader with the blend mode available, which I set to 'Alpha Clip'. I then assigned that new shader to my leaf objects and deleted the old one. Now the trees look ok, in their original scene and in the final scene where they are linked.

I do get an ugly white outline on my alpha cutout from far away.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.