1
$\begingroup$

I've encountered a problem with a transparent material I created to resemble a form of glass. In the scene I have set up, I have a multitude of X "Dummy" Trees propped up in the background to fill the skyline. However, as you can see through the image, the trees that are not behind the POV with the glass look fine while the ones that are behind it act like their alphas are not being used.

enter image description here

Each tree is an 'X' plane with the image of a cycled rendered tree plastered on it. It is made so that only the tree is visible, and the rest of the picture is transparent.

Is this a problem with the texture made for the trees or the window? Since I also noticed that this same kind of glass created some weird effects on UV textures in another part of this scene.

EDIT: After trying the first suggestion I get this: enter image description here

It still seems to be prevalent in the trees, albeit some trees, (which I have pointed to), have the problem fixed, while others in the background still have the black rectangles. To the right is my selections for options and shadow.

Here is a copy of the blend file with the stuff needing fixing selected.

Here is the tree files for the Dummy's: http://imgur.com/a/HTOhC

$\endgroup$
  • $\begingroup$ Is switching to Cycles an option? Why are you using the Blender renderer? $\endgroup$ – John Dvorak Apr 12 '17 at 13:31
  • $\begingroup$ For the scene and circumstances, I cannot switch to Cycles, because then certain materials that I need to have won't be available and will be costly with time. Is this something specific about Blender Internal? $\endgroup$ – Krillinslosingstreak Apr 12 '17 at 13:58
  • $\begingroup$ About the only thing about BI I know is that it's inferior, not designed to create realistic scenes and shouldn't be used. Sorry. $\endgroup$ – John Dvorak Apr 12 '17 at 14:00
  • $\begingroup$ Fine, I'll wait for someone else, I just simply can't use Cycles for the situation. $\endgroup$ – Krillinslosingstreak Apr 12 '17 at 14:19
  • $\begingroup$ I notice that one of the specular sliders are not at zero. This could explain why the borders of the cloud plane are showing up, along with reflected light. For complete border and surface invisibility both specular sliders usually need to be at zero. i.e. the main one in the Material properties, and the one included immediately under the Alpha slider found in the Transparency tab. Additionally you may find it necessary to tick/untick the "Transparency" box found in the plane's general properties. That's the orange cube icon at top. Go down to the "Display" tab. The box is in there. $\endgroup$ – Edgel3D Apr 24 '17 at 1:48
2
$\begingroup$

Your Glass plane uses Raytrace so you need to allocate more depth rays for the amount of transparency changes behind it. I have bumped it up to 6, I guess you'll need more for all those trees?

Depth rays

Alternatively you could switch the transparency type to "Z Trans" but you'll loose some of the nice effects from raytrace.

$\endgroup$
1
$\begingroup$

Under Options for your tree materials, put a check next to Face Textures,
then most importantly, place one next to Face Textures Alpha.

Face Textures

Also be sure to place a check next to Transparency.
It doesn't matter which method you use. That's up to you.

Trans

$\endgroup$
  • $\begingroup$ For some reason it is still not working. I updated the post to include a second picture after I tried your suggestion. In the new picture I can see that some trees have it where the tops are visible without the black rectangles, but for some reason other trees have the blackness still. Should I upload my blender file? Currently I'm thinking it could be something to do with shadows for receiving and casting, but I'm not sure. $\endgroup$ – Krillinslosingstreak Apr 12 '17 at 19:57
  • $\begingroup$ Yeah, I used the "Import Image as Plane" plugin. It may have automatically selected an option while importing. You can try it that way, or upload your blend to blend-exchange.giantcowfilms.com and I'll compare it with what I've got. $\endgroup$ – Doyousketch2 Apr 12 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.