2
$\begingroup$

Good Day Peoples.. :)

I am having trouble with eevee. the cycles end result was pretty good. Lighting wise. But eevee looks rubbish and

I understand that eevee is not Ray Tracing and uses the same tech as games, Rasterization. But I have seen some beautiful results online and want to know what I'm doing wrong.

I have altered heaps of settings, I have tried : Adding indirect light sensors, Changed node setup different ways.. Building normal maps and adding more to node setup Fiddled with lights and turned on contact shadows which gave the image some depth but I still get the overly cartoon vibe

The Image Below shows Cycles / Eevee direct render / Eevee Edited to improve best I can!!

I'd like to get some help with what to try to improve it more.

enter image description here

If anyone wants the blend file I have stored it in my google drive.

https://drive.google.com/open?id=1J7fslQR96G_2p2QVIuT7TwqNGjEdxCmc

If anyone here is up for taking a look at what can be done to improve, I would really appreciate it.

The saved .blend file is for Blender 2.8 (Of Course!) and saved with the setting which gave the 3rd result.

Cheers Shaun

EDIT: I have found that changing 'shadow method' under "Shader Tab" from ESM to VSM I get better quality shadows. But still looking for better quality :)

EDIT: With Help from AxiomDes and trial and error I have found that enabling VSM method shadows, ensuring have checked the items AxiomDes suggests and also playing with contact shadows settings results will improve.

EDIT: Objects with transparency, materials need to have Alpha enabled. (The Daz Model here, I used "Alpha Hashed" for eyeMoisture, and hair objects)

It would be worth noting that between Cycles and Eevee It would be worth just renaming all lighting for cycles as Cycles_lamp1 etc Disable, and making a new set just for Eevee. Some Lamps work well between Cycles and Eevee so this is depending on your scene.

Anyways enter image description here

Thankyou for your help today AxiomDes

Here are my latest results. enter image description here

$\endgroup$
2
$\begingroup$

Try baking a denser and smaller area for your light volume. This should resolve some of the shadows better. I'd also set up lights specifically for Eevee, since the lights from Eevee are not 1:1 with Cycles. If you're not already, turn on soft shadows as well in your shadows option. If you've got subsurface scattering in your scene, make sure it's properly set up within Eevee as well by turning it on.

Edit light probe settings Here are the settings for the Irradience Volume, note the XYZ resolution.

$\endgroup$
  • $\begingroup$ Thankyou for your reply AxiomDes, denser and smaller area for light volumes, can you explain more for me? what do you mean? SoftShadows I have enabled and disabled.. In the Render Tab, I see No Difference! does this need to be setup somewhere else? do I even bother with the Light Probes? Thank-you $\endgroup$ – ToxsickcitY Aug 8 at 4:41
  • $\begingroup$ I also have noticed the World Lighting doesnt do anything (Change strength for example has no difference) I read eevee does not use world lighting? $\endgroup$ – ToxsickcitY Aug 8 at 4:44
  • 1
    $\begingroup$ Make the physical size of the volume smaller, and in the settings for the volume, increase the XYZ resolution, then bake it (it will take longer). The settings are a panel like the material panel or the camera settings panel. World lighting does work in Eevee, make sure you set up a proper hdri though. A flat color will produce flat lighting. If you baked a probe though it will take priority over the lighting so any changes in your world settings would require another bake, or delete the old bake. $\endgroup$ – AxiomDes Aug 8 at 5:48
  • $\begingroup$ Check my edit. Increase the XYZ resolution of the Irradience Volume, and then bake. $\endgroup$ – AxiomDes Aug 8 at 7:40
  • $\begingroup$ Thankyou AxiomDes, I have learnt alot today. the Irradience Volume makes a big difference to where it finds light from, and where to shine. I am still looking for ways to improve the gradient of shadows. it seems that I cannot get eevee to create a nice gradient, shadows seems to be almost like 256color gifs like not enough scale! The biggest change was the change of ESM to VSM.. are there any other tricks to making shadows better? $\endgroup$ – ToxsickcitY Aug 8 at 8:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.