0
$\begingroup$

I'm following along with this video from Khamurai (https://www.youtube.com/watch?v=BT_wsIvJgNk), and in the video, he addresses the point of how to get the vapor trails to appear correctly by setting the material blend setting to "Alpha Blend." However, it does not appear to translate properly into Cycles.

Here is the the preview that I'm getting through Eevee:

Vapor with no opaque black background

And here is the preview that I'm getting through Cycles:

Vapor with opaque black background

In both the 3D viewport (with Cycles enabled) and the Cycles render, the opaque black background shows up when it is not desired.

In the Eevee engine, materials have a Settings option where you can change the blend mode to "Alpha Blend," which makes things work as desired, but it does not appear that this same effect is possible in Cycles (at least not in the same way).

Does anyone know how to bridge the settings gap from Eevee to Cycles in this instance?

$\endgroup$

1 Answer 1

0
$\begingroup$

Cycles doesn't have that setting because it doesn't have this kind of abstractions to begin with. It you tell it to display things transparent, it just does it.

To me, it looks like you are trying to preview your material with your viewport's shading set to Material. The issue is: that view is basically Eevee with specific settings. If you want to see transparency correctly in Material view, switch to Eevee, set the Blend modes correctly, then switch back to Cycles.

But more importantly, you shouldn't expect the Material view to give you an accurate representation of Cycles materials. The only thing that can do that is Cycles itself. For this, set your viewport shading to Rendered.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .