0
$\begingroup$

I seem to be having issues getting my character to follow a curved path I've set up. I've been playing around with it and nothing seems to work properly. Whether I parent the bones in Object Mode to the path using Ctrl + P, or adding a Constraint to the bones, my character either just walks on the spot, walks around the path in a diagonal position, or walks but then the animation stops. Even if I adjust the amount of repeated steps, the scale, the amount of frames etc. nothing seems to work. I think the axis are a bit messed up with my rig somewhere.

Can someone please take a look at my file and help me solve this? I'm completely at a loss how to get this working properly. The default frames for my walking animation is 40.

Thanks.

$\endgroup$
1
$\begingroup$
  • Put the origin of the curve at its beginning vertex (shift ctrl alt C > Origin to 3D Cursor).
  • Disable the different Follow Path constraints of the character objects (you don’t need them).
  • Switch your armature to Object mode, give it a Follow Path constraint, choose the curve as Target, enable the Follow Curve option.
  • Clear the Location of the armature with an alt G.
  • Rotate the armature the way it is supposed to be (R+Z+180).
  • Select the curve.
  • Open the Graph Editor, display the properties panel (N), open the Modifiers tab and deactivate the Generator (which is automatically created with the Follow Path but won't help you here).
  • On the Timeline go to frame 0.
  • Keep the curve selected and go to the Properties panel > Data > Path Animation, choose an Evaluation Time of 0 and and insert a keyframe.
  • On the Timeline go to the frame you want, and in the Properties panel > Data > Path Animation, insert a new keyframe in the Evaluation Time with the value you want.
  • In the Graph Editor, put your mouse over the graph and press T > Set Keyframe Interpolation, and choose Linear so that the movement along the curve is linear.

You can speed up the animation of the character along the curve with the Evaluation Time value.

You can speed up the walk cycle speed itself in the NLA Editor (right properties panel > Scale value).

But first, make sure first that no action is loaded in the Dopesheet editor, otherwise this action will play over the NLA strip.

Also, note that you can quickly edit the action of a NLA strip, selecting the strip and pressing Tab. The pin (on the left of the track) will allow you to see the animation with or without the NLA settings effect.

$\endgroup$
  • $\begingroup$ Thank you so much for your help. That's pretty much got it. :D However, I can't seem to get my character to continuously walk from start to finish. Even when adjusting the scale and number of repeated steps. He gets to frame 40 and just stops animating. If I put the total frames to 40, he'll animate to the end, but the walking will be far too quick. Again, adjusting the scale and repeat doesn't do much. $\endgroup$ – DustyShinigami Jan 5 at 2:12
  • $\begingroup$ Also, what exactly does that Generator do under Modifiers? And why do keyframes need to be added to the curve itself? Thanks. $\endgroup$ – DustyShinigami Jan 5 at 2:13
  • $\begingroup$ As soon as you create a Follow Path constraint to your object it automatically creates a Generator, but it's much more convenient to control the animation with keyframes and graph curves so most of the time I guess you'll have to delete it. $\endgroup$ – moonboots Jan 5 at 9:59
  • $\begingroup$ about your walk, you need to play with the speed along the path, with the amount and scale of the strip, etc... also you have to avoid any feet gliding, it's a bit hard to fix of course ;) $\endgroup$ – moonboots Jan 5 at 10:02
  • $\begingroup$ I can't seem to get it. :-\ I keep adjusting the number of frames, scale, repeated steps, but as I say, it either animates from start to finish too fast, or the walk cycle stops at frame 40 every time even if I manage to slow it down. It never reaches the end of the path. $\endgroup$ – DustyShinigami Jan 5 at 23:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.