1
$\begingroup$

I am very new to blender but have 3d modeling experience from other software's and have been playing with the bone rigging and armature stuff in blender. I modeled this character and assumed for weighting I should join all the meshes belonging to the character together, so I selected everything and join with ctrl + j. enter image description here I rigged my bones and have the relationships all setup properly, so when I move the bones individually, everything works fine. enter image description here enter image description here

As soon as I try to tell blender to join the bones to the mesh, this is where things seem to go awry. I shift click the character mesh + bones, go to pose mode, select all the bones, and ctrl + p and select "with automatic weights. It seems to work great but when moving the bones, the arms and legs meshed get distorted unequally when the symmetric bones are moved the same amount. enter image description here

enter image description here

I have checked weight paint and everything seems ok, what is going wrong and how do I fix this!

Link to blend file

enter image description here

$\endgroup$
2
  • $\begingroup$ hello could you please share your file? blend-exchange.com $\endgroup$
    – moonboots
    Nov 25 at 8:34
  • $\begingroup$ I added a hyperlink to my google drive where the blend file can be downloaded. $\endgroup$ Nov 25 at 8:58

1 Answer 1

0
$\begingroup$

Check the normals, as you can see they are inverted on the arm and on the leg, so in Edit mode select all and press ShiftN. Also apply the scale of the armature and object, and parent again.

enter image description here

$\endgroup$
1
  • $\begingroup$ Yay it worked! thank you so much for your help! I have been stuck on this for like 5 hours at least... $\endgroup$ Nov 25 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.