0
$\begingroup$

https://cdn.discordapp.com/attachments/404810103661920259/501202949272502272/unknown.png

I've made a High to Low poly model, and after using the ctrl+alt+shift+m command to find non-manifold elements, I've found several as shown in the .png which is edges and vertexes across the model as well as the uv wrapping. How do I fix these non-manifold elements? I appreciate anybody's time and effort in helping solve this issue!

$\endgroup$
2
$\begingroup$

As far as fixing nonmanifold issues are concerned, you don't need to worry about the UV unwrapping at all (except for possibly having to unwrap it again when you change your vertices around).

The problem you have in the middle probably happened after you applied your mirror modifier, but it's an easy fix. Make sure just that section is selected, then scale it to 0 on the x axis. LEAVE IT SELECTED. Next you're going to go to your search bar (space in 2.79) and start typing in 'remove'. A few options should pop up, but what you want is remove doubles. You can also access it from the 'W' menu, but sometimes it just doesn't show up for me, so that's an alternative method.

Your other manifold problem looks like you might have internal faces. To check, go to face mode and see if you see any of those floating dots inside your model. If you do, move back into edge select and only select the edges on the inside (so you won't make holes in your model) and delete them.

I hope this helps!

$\endgroup$
0
$\begingroup$

Okay, so upon troubleshooting the mesh, my actual underlying issue was to essentially make the mesh workable with a third party program called Quixel Suite 2. However, UV errors led me to believe the non-manifold elements in the mesh was the issue. It turns out that wasn't the issue, so I no longer need to necessarily worry about them as of now.

But, I do want to clarify how I solved the non-manifold errors anyway for anyone else who may have similar problems. I used the retopo-flow addon and a symmetry/mirror modifier for the x-axis, and then I created one side of the mesh which was completed with said modifier.

I simply applied by clicking "apply" for the mirror modifier and that solved the large central manifold line visible in the image above. That contained most of the non-manifold elements.

There were no doubles as there were 0 vertexes deleted after doing as suggested.

There was only one non-manifold element that remained (I guess two if you count the mirroring modifier), which, with elucidation from your post, turned out to not be a internal face, but a hidden edge. Close enough. That'd be the line visible in the image which is the singular yellow line above the mesh's thighs.

Lastly, I installed the Meshlint addon, supposedly "Like Spell-checking for your Meshes", that searches for errors/things-to-note-carefully in a mesh such as the non-manifold elements that plagued mine, tris, n-gons, etc. That should help catch the problem before it begins next time.

Thanks for your help, I hope that this post may help others who have similar issues.

$\endgroup$
  • $\begingroup$ I appreciate you sharing your solution. Are these addons available directly in Blender, or are they downloaded separately? $\endgroup$ – Lee Oct 15 '18 at 19:34
  • $\begingroup$ I believe both addons need to be downloaded separately. Here's the link to Retopo-flow, which is time-saving for retopology. link. And the link to Meshlint link Both are free full versions. Retopo-flow's retail allows you to get customer support for it, though. $\endgroup$ – Near Oct 15 '18 at 19:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.