0
$\begingroup$

I'm working on a space scene in blender and I've run into an issue with my shadows. In normal planet scenes, the shadows on the planet are so dark you cannot see the rest of it. With mine, even when I turn the sun lamp off or put it on 0 it's still not dark enough to hide the rest of the planet.

Uploaded by CraftyMaelyss, do not copy, edit or redistribute

I checked to see if it's the settings but from the looks of it, everything seems fine, so I'm really at a loss.

I've used a UV sphere to make the space scene like in this tutorial if it helps at all: https://www.youtube.com/watch?v=uWSeBoIDJV4&t=551s

I'm starting to get the hang of blender but I'm nowhere near being a pro so please include screenshots to help explain your solutions to this problem.

$\endgroup$
  • 2
    $\begingroup$ Shadow is absence of light: is there any other light source other than this lamp? Is the World emitting some light? Could you show the World tab? How's your object's size compared to the size of the lamp? BTW, the "Cast shadow" option in disabled for this lamp. $\endgroup$ – Carlo Jun 17 '18 at 8:44
  • 1
    $\begingroup$ You may need to change your world settings to reduce the background ambient light in your scene. $\endgroup$ – Tavi Kohn Jun 17 '18 at 8:56
2
$\begingroup$

If your doing a space scene, there isn't an atmosphere to emit or bounce light. therefore make sure the world's light is set to absolute black and from there you have full control of the lights that comes from our sun or your main light source.

Tip: set the size of your sun to something between 0 - 0.05, it makes it sharper and gives the illusion of a very huge object, study the physics if you want to understand why that happens.

Till next time

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.