2
$\begingroup$

I'm a beginner in blender and i can't figure out why the shadows in my scene are different in live render and final render. The shadows seem to be less pronounced in the final render. That makes it really time consuming to fine tune the lamp size and strength values. I'm using a shadow catcher and a background image with one lamp (sun) and a world background with the strength of 1.0.

Color management settings: Color Space & Display Device: sRGB, View: default, Exposure: 0, Gamma: 1, Look: none, Use curves: off

  • Live render:

Live render

  • Final render:

Final render

  • Composition nodes:

Composition nodes

EDIT:

When changing the world background strength to 0.0 the images become more similar but still not the same and i need the background for reflections.

background strength 0.0

EDIT:

I reproduced the problem in a new file. Download for blender 2.79.

The shadow in the preview is clearly darken than in the final render:

Example problem

$\endgroup$
  • 1
    $\begingroup$ Probably because the different amount of samples in the render settings for render view and final render. If you think the render view is good enough decrease the final render samples to the render view's value. $\endgroup$ – FFeller May 12 at 16:28
  • $\begingroup$ I have both render and preview samples set to 64 under scene → sampling $\endgroup$ – Ingmar05 May 12 at 16:30
  • $\begingroup$ What settings are you using for color management? $\endgroup$ – cegaton May 12 at 16:39
  • $\begingroup$ Color Space & Display Device: sRGB, View: default, Exposure: 0, Gamma: 1, Look: none, Use curves: off $\endgroup$ – Ingmar05 May 12 at 16:43
1
$\begingroup$

This probably not a bug, but differences in settings between viewport/preview and the final render.

Checklist:

  1. Check that all objects that appear in the preview also appear in the final render, especially lamps. See: https://blender.stackexchange.com/a/1114/245 .1

  2. Check that the sampling settings are the same for preview and final render. See https://blender.stackexchange.com/a/111591/245 for reference.

  3. For completeness but probably not relevant: Check the modifiers for any difference between preview and final render.

Given your description there seems to be a problem in the rendering section so you might also use this answer for tracking down your problem.

I specifically think that the amount of bounces is lower in the preview then in the final render. The increased diffuse lighting makes the shadow lighter.

EDIT:

The problem seems to be in the node setup:

The problem is, that the shadow has a strange mix between alpha and color:

The diameter of the shadow changes with the threshhold on the alpha channel! .1 .8

Maybe you could try to use a shadowcatcher material/setup as described here.

Investigating further, I think that you set up everything the right way, but this might be indeed a shortcoming of blender as discussed in the developemnt group here.

$\endgroup$
  • $\begingroup$ I can't seem to find different bounces settings for render and preview $\endgroup$ – Ingmar05 May 12 at 20:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.