11
$\begingroup$

When I try to bake a texture in Cycles, the baked texture is completely black, however it looks fine on the Render Preview. I have tried recalculating normals, but it didn´t fix the issue. I have no idea what else to do. Here I have the .blend file: http://pasteall.org/blend/index.php?id=48466

$\endgroup$
7
  • 1
    $\begingroup$ Can you show here something else in addition to the file? Like baking options, material settings.. As without downloading your file the question is asking for nothing (and as you uploaded file to pastell link will be invalid in 5 months). $\endgroup$
    – Mr Zak
    Dec 3, 2017 at 20:23
  • $\begingroup$ Direct, Indirect and Color are enabled in Baking settings, bake type is Diffuse. Here are the nodes for the main material: i.imgur.com/r6pSOcz.png. And the nodes for the second material:i.imgur.com/D3txbqA.png $\endgroup$
    – Magnus
    Dec 3, 2017 at 20:51
  • $\begingroup$ I just checked your file and the black texture is never used in the material that is on the object, that is why everything is looking fine when rendered. If you select the texture in the material on the object is shows up black as expected. $\endgroup$
    – Brenticus
    Dec 3, 2017 at 20:53
  • $\begingroup$ Hard to tell if is related but Image Texture with texture to baked to has to be selected in order to receive bake. "Direct, Indirect" means shadows will be taken into account when baking thus making it depending on lighting in scene $\endgroup$
    – Mr Zak
    Dec 3, 2017 at 20:54
  • $\begingroup$ I have the image texture to bake selected, but it still renders to black. $\endgroup$
    – Magnus
    Dec 4, 2017 at 23:16

4 Answers 4

11
$\begingroup$

It turned out that I tried to render Diffuse, but the Principled shader does not render diffuse. Rendering Glossy worked.

$\endgroup$
5
  • 4
    $\begingroup$ The Principled shader will render for a Combined bake that includes Diffuse. I just ran into a similar problem, in my case, the Principled shader bakes wouldn't work for a metallic material. The bake worked fine when i switched to a material based on diffuse and glossy shaders. But i have used the principled shader for bakes just fine when the metallic field was at 0. $\endgroup$
    – kim holder
    Jan 18, 2018 at 22:59
  • 1
    $\begingroup$ Maybe it bakes differently depending on the metallic field? $\endgroup$
    – Magnus
    Jan 19, 2018 at 23:49
  • 2
    $\begingroup$ As it happens, i put on a Blender Guru video while waiting for something to bake, one about PBR metal materials. He says metallic materials are all glossy, they have no diffuse element. So, after this bake, which won't end until tomorrow, i'm going to test one of the metal bits in my scene, baking it with a full combined bake. I have been excluding glossy. $\endgroup$
    – kim holder
    Jan 20, 2018 at 1:04
  • 3
    $\begingroup$ Yeah, once i did that it worked fine. If the material is metallic, the principled shader requires that glossy is part of the bake. $\endgroup$
    – kim holder
    Jan 23, 2018 at 16:37
  • 2
    $\begingroup$ Thank you! Thank you! I've been hitting this black bake issue for literally 8 hours. Now the sweetness of success and relief. $\endgroup$
    – Fiddy Bux
    Jul 30, 2019 at 23:03
4
$\begingroup$

Adding this in case it helps someone with the same issue....

Another reason you might get a black bake is if objects are in the way. In Blender 2.8 this is incredibly easy to do without realising it. Even if the 'eye' icons of other meshes in the Outliner are 'closed' (i.e. the objects are hidden), they'll still get in the way of the texture baking.

The answer is to just move all of the objects that aren't part of the bake into a new Collection and disable that.

$\endgroup$
1
  • $\begingroup$ Yes! This helped me. I couldn't figure out why my bake wasn't working and it was driving me nuts lol. Thanks! $\endgroup$
    – Geri
    Sep 13, 2021 at 20:39
0
$\begingroup$

to bake an object with no scene lighting:

(worked for me)

  1. set the source material(s) emission to white (full bright)
    properties -> Material properties -> [material] -> Surface -> principled bsdf -> Emission = white
  2. uncheck "emit" under the bake's "influence"
    properties -> Render Properties -> Render Engine = Cycles properties -> Render Properties -> Bake -> Influence -> Direct [eanbled] and Indirect [enabled] -> Emit [uncheck]

this helped bake the material as if it were full bright

$\endgroup$
3
-1
$\begingroup$

I can only use Blender 2.79 (no GPU), and I ran into this problem many times trying to cut down on render time. I read the Blender manual, and it said that the material out node must be selected to properly bake textures. I tried it and I haven't been getting the black textures any more.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .