2
$\begingroup$

I'm trying to render a simple animation of the camera circling a lit candle, with particle emission beginning at frame -100 so it's lit before frame 1.

To speed things up I'm rendering to pngs across multiple computers. For example I've set things up to render from frame 1, frame 20, frame 40, and frame 60 on four PCs. However the first few frames on each computer seem to show emission starting again, i.e. frames 20, 40, and 60 show no particles.

How can I fix this so I can collate all my files at the end for one smooth flame animation? Is this a known issue?

Any advice or tips for a novice would be great!

$\endgroup$
0
$\begingroup$

So I've discovered what causes this. When you're animated from a frame that isn't frame 1, in the timeline you have to make sure you're current time point is on frame 1. If you have the frame you're rendering from as your time point then it begins particle emission from that frame hence a few frames of no emission.

$\endgroup$
0
$\begingroup$

If your emission end time is not 1 with your start time it retains previous knowledge for the previous particles not yet re-emitted.

Setting the end to 1 and back again seems to reset it. As I recall it was a painful thing in Houdini to go back to free 1 since it I guess in Blender terms cleared your bake. Maybe if you animate it from frame zero you get the proper reset of all particles. Totally painful bug I'm sure will get fixed. This is happening on 2.79...

Oh wait this is not keyable either?! Lame... again. F! ... so you have to remember to do it manually before you render, or every time you want to start at the beginning and not see previous pre-emission positions I guess.

This might have something to do with one particle system getting keys from another particle system in 'Keyed' mode or my particulars. Alas I doubt that has anything to do with.

Update: It's also seemingly intermittently solving this for me. A tangle of trouble. Also I'm seeing a cache tab under emission now. I was trying to clean the Scene Cache and after completely deleting the Rigid Body World which I never baked did nothing.

Anyway it's glitched when it loops so it's definitely buggy. Maybe baking is the only way. No the baking returns with same problem particles from middle of animation on the first frame, not properly reset to their initial state. I know seems like a no-brainer right? Well somebodies pulling a no-brainer here and it's not me.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.