2
$\begingroup$

I am a Blender newbie, working through the manual trying to learn modeling. I have found that when I create a new document (reload Startup file), the block object appears with the 3D manipulator showing, and when I click and drag on any of the three arrows, the movement of the block is constrained to the appropriate axis, as I would expect.

But, when I load my working document with some objects I've been playing with, the manipulators do NOT constrain the motion when I drag any of the arrows. The behavior is exactly like I'm clicking inside the white circle, but I'm definitely clicking well outside of it.

I can't seem to find any setting or mode difference that I can change to get the manipulators to work properly. Any ideas as to what obscure mode or setting I could change to restore the axis constraining behavior?

Nothing I have read in the manual suggests that there's any mode or option setting that would disable the automatic axis constraints when you drag on a manipulator arrow.

One possible clue is that I am modeling small objects just a few cm across, whereas the new document's default block is 2m across. Could my issue be caused by zooming in too far?

I have found other ways to accomplish the same axis-constrained moves, but I'd really like to use the 3d manipulator handles, and I'd like to understand why they're not working in my file.

Thanks in advance for any suggestions.

$\endgroup$
  • 3
    $\begingroup$ Is it possible you could upload a file demonstrating this behavior? $\endgroup$ – gandalf3 Dec 17 '16 at 6:06
1
$\begingroup$

I found the problem. I'm not sure I have all the exact details, but in essence, the problem had to do with the scaling and dimensions within my model file. I mentioned that the behavior I saw was as though I was clicking inside the white circle. My model was imported from an STL file where the size of the largest object was about 6cm across. In order to get the sizes to look right, I made the following settings, which led to the problem: 1) In the properties panel (the "N" window), I set the Scale to 0.001 for each object in the model 2) In the Properties Editor (not the N window), on the Scene tab, I set Unit Scale to 1.0.

The solution I found was to reset the individual object scale values to 1.0, and then under Properties>Scene, I set the Unit Scale to 0.001. After making this change, the net size of things on the screen is the same, but Blender seems happier dealing with objects at 1.0 scale rather than .001 scale, and the 3D manipulator now works as expected. This is probably the more correct way to do things, and I learn best by example, so I'll remember this. I just wonder if maybe there's a bug in Blender because it seems that the effective size of the little white circle in the middle of the 3D manipulator is larger than the size on screen, like it's not following the object scale properly. Anyway, I hope my answer helps others at some point. :-)

$\endgroup$
0
$\begingroup$

I had same problem. What helped me was to increase start value in clip setting of view tab (panel you toggle with N) from 1mm to 1 cm. Hope this helps someone.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.