1
$\begingroup$

Why does this happen when I cut off the top of a cylinder? When I turn it around, it will only show the texture from the front.

enter image description here enter image description here

How can I get it right? Is it because it doesn't have an UV on the inside? How can I get this best?

$\endgroup$

1 Answer 1

2
$\begingroup$

This usually happens when you have Backface Culling enabled. Make sure it is unchecked as shown on the picture below.

enter image description here

$\endgroup$
7
  • $\begingroup$ How would it work with texturing? Will i get two sides in the UV? I need to import this mesh in another program, so not sure if this is just for blender. $\endgroup$
    – Fur
    Oct 25, 2016 at 18:43
  • $\begingroup$ @Fur Backface culling is just a display option, it has no effect on your object. Also there is no such thing as "two sides of the UV", if there is only one face to texture, then for that set of texture coordinates it will display the same when viewed from one side or the other. If you want different coordinates for front and back you will most likely have to create thickness with new faces, unless the other program supports different backface shading. $\endgroup$ Oct 25, 2016 at 19:21
  • 2
    $\begingroup$ You would have only 1 side in the UV (so the model would be textured from both sides equally). If you want to texture it differently on each side you can use the Soldify modifier, which basically adds thickness to your model (creates new geometry). Game engines usually render only the front-face (same as Backface Culling enabled) to save resources. $\endgroup$ Oct 25, 2016 at 19:23
  • $\begingroup$ The problem is that it does not texture on both sides. When i import the file in my other program, it just looks like the picture in my first comment. Its probably cause of the program, but what would be best advice to get texture inside in another way? Maybe adding another object, but what? $\endgroup$
    – Fur
    Oct 25, 2016 at 19:36
  • $\begingroup$ Yes, it's most probably caused by the other program. So the best way is to use the Soldify modifier (link), which automatically generates the backface geometry for you. $\endgroup$ Oct 25, 2016 at 19:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .