0
$\begingroup$

I think I can "Fix" this by deleting the chess board and appending an older version of the scene which only had the chessboard, however I'd like to understand whats going on.

It appears that only certain squares are taking my rendering options.

What I've tried doing to fix this.

  • Removing and recreating lights, in case it was a lighting issue.

  • Merging vertices, (in case it was in issue with geometry)

  • Reassigning materials to the squares.

The initial scene notice the lines on the middle of the board.

initial scene

changing the material for white and black Changed colours

Note only the middle squares are showing as taking the texture in rendered.

This is the same in preview render and full render.

Only with blender render. If I choose cycles render then the board looks correct. (i.e. its taken the colors given)

Any idea whats going on?

Uploaded file here.

$\endgroup$
  • 1
    $\begingroup$ It's not very clear what you are asking. Could you add a link to the blender file to your question. As for the viewport not showing all edges it's an automatic internal optimization to improve display performance. You can customize it per object in the Properties Window > Object and choose the option "display all edges". $\endgroup$ – Duarte Farrajota Ramos Jun 19 '16 at 13:20
  • $\begingroup$ The reason for the wireframe comment was I thought maybe it was a symptom of the same problem. I've been corrected on that and I'm going to remove it from the question. $\endgroup$ – Wes Jun 19 '16 at 15:01
  • $\begingroup$ Related - blender.stackexchange.com/questions/7113/… $\endgroup$ – Mr Zak Jun 19 '16 at 16:04
2
$\begingroup$

These are the shading effects visible on the mesh. They were added with Tangent Shading from the Materials > Shading rollout.

screenshot of tangent shading checked

From the manual:

Tangent Shading
Use the material’s tangent vector instead of the normal for shading - for anisotropic shading effects (e.g. soft hair and brushed metal).

You could see on the preview white line across the ball. Once you turn off the option the preview will be changed.
When unchecked the mesh will be rendered as usual:

screenshot of tangent ucnhecked

If you unwrap the mesh, the tangent shading will use the UV map to define the direction of shading and it won't be interrupted as it is in the original file. See related topic - Strange anisotropic artifacts?

$\endgroup$
  • $\begingroup$ Thanks I would never guess that it worked like this. Seems strange that the tangent shading of one material effects the other. $\endgroup$ – Wes Jun 19 '16 at 16:42
  • $\begingroup$ @Wes shading of one material doesn't affect another one as I saw from the file; it's just that both materials had Tangent Shading turned on. $\endgroup$ – Mr Zak Jun 19 '16 at 19:55
  • $\begingroup$ The artifacts on the white squares didn't disappear until I removed the tangent from the black squares or vise versa. I can't remember which order I did it in now. $\endgroup$ – Wes Jun 19 '16 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.