I am importing a colored .ply file, which is basically an output of a 3D scan. When I import it in Blender internal, and tick the checkbox "Textured Solid" in the menu, the color shows up on the 3D model. No issues so far. Now when I change it to Cycles, I am not able to see the colors. Colors on the object change to the default grey.

I have checked the following questions which were previously asked:

Textures disappear when the rendering engine is switched to cycles

Textures and colors not imported from OBJ file when using Cycles render

They talk about plug-in which converts materials or textures added in Blender Internal to be compatible with Cycles. But in my case, there are no materials that I am adding. The texture associated with .ply is not shown in the materials or texture section. I am not using any UV maps also. So, I am not able to figure out how to turn on the texture associated with the ply file in the Cycles Render. There is no .mtl kind of a material file with .ply

  • Have you tried importing into cycles directly? – schustudrai Feb 17 '16 at 15:45
  • Yes. Nothing changes. It is all grey. – Sum-Al Feb 18 '16 at 18:06

In the materials panel, go to the Options section, and set the checkbox for Vertex Color Paint.

  • My materials panel looks like this drive.google.com/file/d/0B_NsSAqhnSwRYkctX0U2XzFQQk0/… Can't really see options section or anything of that sorts – Sum-Al Feb 18 '16 at 18:01
  • Add a material, then it should show up. – Rick Riggs Feb 19 '16 at 16:18
  • Got it. Thanks for the help. Figured it out. – Sum-Al Feb 21 '16 at 18:57
  • 3
    Don't forget to accept the answer, if it helped ;-) @RickRiggs, Adding that detail to you answer would be really helpful – Matt May 19 '16 at 18:13

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.