0
$\begingroup$

How are they different? enter image description here

enter image description here

When I see these examples, I can see that in Blender Internal the map is much cleaner. It looks like another model with X Ray enabled. But, in cycles the normal map is a little messy. How is the map different from Internal and cycles and how can I get the normal map results in cycles as in Internal?

Edit: There is the file - http://www.pasteall.org/blend/29913

Note - The scene in blender internal is on the first layer and the scene for cycles in on another layer.

Here is the texture - enter image description here

Unwrap the model with Smart UV Project so that it fits the normal map texture or you can bake one of your own.

Edit: Node set-up - enter image description here

Edit: I tried user2926289's upproach but for some reason its still not as good as in blender internal. Any other ideas?

Blender Internal - enter image description here user2926289's approach in cycles - enter image description here

$\endgroup$
  • $\begingroup$ can you post a .blend? (This might be a mistake in your setup) $\endgroup$ – GiantCowFilms Jun 20 '14 at 20:40
  • $\begingroup$ Sorry, I don't have the file, but I did the same scene twice and I get the same results. The geometry value in Blender Internal was by default and in cycles the strength of the normal map node was 0.800. It was the same Unwrap and normal map texture in Internal just as in cycles. I'll make a blend file and post it here. $\endgroup$ – Vladimir Jun 20 '14 at 21:42
  • $\begingroup$ Related: blender.stackexchange.com/q/8129/599 $\endgroup$ – gandalf3 Jun 21 '14 at 1:19
  • $\begingroup$ Thanks Gandalf3, but I'm aiming strongly for a normal map because it is much more sophisticated then the bump map (the bump goes only in height, while the normal goes in other directions, as far as I know). $\endgroup$ – Vladimir Jun 21 '14 at 2:08
  • $\begingroup$ Note that your cycles example has shadows while the BI one does not. This accounts for some of the differences, but I think there is still something funny with the ear.. $\endgroup$ – gandalf3 Jun 21 '14 at 2:16
2
$\begingroup$

There is an error in your node setup: Yours: enter image description here

Correct: enter image description here

Note that the normal value gets plugged into the normal option on the shader node, not into the displacement.

$\endgroup$
  • $\begingroup$ Thanks. I can see its better now, but its still not as good as the internal render engine (I edited my question if you want to see what I mean). Any other ideas? $\endgroup$ – Vladimir Jun 21 '14 at 2:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.