1
$\begingroup$

I'm using the Blender render, and miss a texture repeat option I know from OpenGL. It is used in one model which has been finished poly-wise, but texture mapping is wrong.

Look at our good old Lakitu friend here, who has obvious texturing issues: enter image description here

If you look at the UV mapping on the left, the source to the texturing issue becomes clear: It would be mapped correctly only if the texture would be repeated and mirrored outside its bounds (as if you would use GL_MIRRORED_REPEAT in OpenGL).

However, I do not find such an option in the texture repeat options of the Blender render. Can I only fix this by manually modifying the out-of-bounds UVs (mirroring them back into the texture space and splitting triangles spanning the texture borders)?

$\endgroup$
6
  • $\begingroup$ try to delete the incorrect texture part and apply the Mirror Modifier again $\endgroup$
    – A.D.
    Aug 16, 2015 at 19:31
  • 1
    $\begingroup$ Will using Mirror option from Image Mapping scroll help ? It may mirror your texture along X, Y or both axes. $\endgroup$
    – Mr Zak
    Aug 16, 2015 at 19:54
  • $\begingroup$ @IgorTatarnikov: That wouldn't be an optimal solution, as the model should stay untouched, and some triangles are not aligned on the middle of the mesh. $\endgroup$
    – Ray
    Aug 16, 2015 at 19:58
  • $\begingroup$ @MrZak: You're right... it looked like these options were disabled (half-transparent checkboxes), so I didn't click them! That's exactly what I needed. If you make that an answer, I'll accept it. $\endgroup$
    – Ray
    Aug 16, 2015 at 19:58
  • 1
    $\begingroup$ What Blender version are you referring to for these comments? That link to the Image Mapping documentation is no longer functional - the documentation defaults to version 2.81, and it doesn't seem to be available in version 2.79 either. Blender is not helping its documentation issues by invalidating old links. $\endgroup$ Nov 27, 2019 at 22:31

2 Answers 2

3
$\begingroup$

In order to repeat the texture, at the same time mirroring it, you should check 2 options in the Image Mapping scroll:

  1. increase value of the Repeat slider to something more, than 1 (otherwise Mirror options will continue being disabled, like you've mentioned);

  2. check Mirror X and / or Mirror Y checkboxes.

enter image description here

The texture will be repeating as the pattern, mirrored on selected axes.

$\endgroup$
0
2
$\begingroup$

I had the same problem and this answer solved it. You can use the ping-pong node:

enter image description here

The 'image mapping scroll' from Mr Zak's seems to have disappeared in newer Blender versions.

The downside to this method is that the texture is un-mirrored again if you export, to .FBX for example. If someone knows how to avoid that, please leave a comment or edit this answer...

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .