I imported an FBX model of an object in Blender 3.0.0 ( a 3rd party model, does not have any textures included). The object shows up fine in the Viewport and vertices are showing up in edit mode

I need to add a image texture to the object, so I created a material, provided the image texture, selected specific vertices of the object and assigned to the material

Now I need to UV map the vertices to specific points in the image. This is where I am stuck. I selected the vertices in Edit mode, then I opened up the UV Editor window, and no vertices show up. I pressed the U key, and unwrapping does not really happen.

I opened the texture image in the UV Editor and tried unwrapping again, no luck. The selected vertices just won't show up. The FBX model has a bunch of triangles, almost no quads but I guess that should not be a problem at least for UV mapping. Also, after importing the FBX model (and before any UV mapping effort), I scaled it to 100x to fit other objects in the scene.

When I render, I see the object getting the color of the image texture, so material assignment is probably happening fine. But I need to have specific portions of the image texture to be mapped to specific vertices and that's where I have the issue. UV mapping is working for all the other objects in the scene. Weird thing is, for all the other objects, I see the "UV Selection Mode" and "UV Sync Selection" buttons, but for the problem object, I don't see those buttons in the top right of the UV editor.

  • $\begingroup$ This is question has very little to work with can you provide some images or more context to what exactly the problem with the UV editor is? eg:- you could be in the wrong interaction mode or havent selected the texture to start on. $\endgroup$
    – Lester
    May 30, 2022 at 10:32

1 Answer 1


Some things I can thing of: did you apply rotation and mainly scale to the object? CTRL + A in object mode, then apply scale. Did you reset the UV map? In edit mode press “u” for unwrap options and select “Reset”. Something else to try is deleting de UVmap name in the object properties and create a new one. Cheers.

  • $\begingroup$ Thanks Damian, I got some pointers from your comment and it worked out! Resetting the map solved the issue! $\endgroup$ May 30, 2022 at 17:33
  • $\begingroup$ Glad to hear! Would you mind voting my answer or accepting it so it’s solved? Thanks $\endgroup$
    – Damian
    Jun 1, 2022 at 10:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .