2
$\begingroup$

I having problems to see weight effect area in the viewport.

For example this file:
https://dl.dropboxusercontent.com/u/51093542/35-minecraft-char.blend (right-click and 'Save As' to download .blend file)

used in this tutorial:

https://www.youtube.com/watch?v=rkT92aoMpP0

Compare how its shown in the video (around 5:23) and this
weight painting on my model

In another test if I pose the object and try to weight paint on it: weight painting on a test model

So obviously the weights are being applied to the object, I just can't see it like its supposed to do. Any ideas?

$\endgroup$
1
$\begingroup$

The file you sent seems to work fine for me (Running Blender version 2.75a): enter image description here

Make sure "Custom Weight Paint Range" in the User Preferences under System is unticked: enter image description here

$\endgroup$
  • $\begingroup$ Is disabled for me too, and the worst part is, if I try to create a new paint range it also doesn't show correctly. Maybe theres something with my graphics card? $\endgroup$ – Tobias Felipe Aug 3 '15 at 12:12
  • $\begingroup$ This process should not have anything to do with the graphics card ... I believe. $\endgroup$ – hawkenfox Jan 26 '16 at 6:07
1
$\begingroup$

It was actually a bug, it works on version 2.72, but not in newer versions, is something related to my setup I think (OS or drivers), reporting to developers. Until then I'll have to use the old version I guess.

$\endgroup$
  • $\begingroup$ Can you see the weights as normal in a new file? $\endgroup$ – PGmath Aug 4 '15 at 0:13
  • $\begingroup$ @PGmath, no I can't, the error is not in the file, it's just a example at hand, I tested in other files as well. $\endgroup$ – Tobias Felipe Aug 4 '15 at 0:17
  • $\begingroup$ You may want to report the bug. $\endgroup$ – PGmath Aug 4 '15 at 0:19
  • $\begingroup$ I reported, is there, but I can see that this are not high priority, may take a while. $\endgroup$ – Tobias Felipe Aug 4 '15 at 0:23
0
$\begingroup$

If none of the vertex groups show up in weight paint mode, then it could be an error in the settings or just a program issue (if you don't have the latest version, update).

For a simple model like this, one workaround is to set the vertex group weights manually. For instance, go into edit mode, select all and remove it from the head vertex group, then select only the head geometry (you can hit L over it to select connected), and hit assign. For those half-way rings at the elbows and knees, you'll have to set the weight to 0.500 before assigning.

Read here if this doesn't make any sense: https://www.blender.org/manual/modeling/meshes/vertex_groups/vertex_groups.html

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.