0
$\begingroup$

So I have a mesh that's touching another. I gave it a bendy bone -- and following this tutorial, I added two bones at the head and the tail of the bone that I used as "custom handler references" -- then parented the bone to the mesh "With automatic weight".

Works great, except the base of the mesh lifts off the mesh it's touching for some movements.

I thought this'd be easy to fix, I'd simply weight-paint it in such a way that the bendy bones don't affect a very small portion of the mesh where the two meshes are connected. That way, it would still bend and flex as I want it to but without breaking connection to the other mesh.

Except when I go into weight paint mode, the mesh is all black.

Right, so I have since figured out that the mesh is all black because the light is behind it.

So let's pull the light in front.

Now, the mesh's no longer black and its texture is shown. BUT still no weights.

I tried and I can paint weights. I just cannot see the weights nor what I draw, which renders its usefulness somewhat ... limited.

I clicked through all viewpoint shading options and none of them seem to be helpful.

Using Blender 2.79b.

As far as options go,

"Show Zero Weights" is set to "None"
"Restrict" is off
Ctrl+A didn't do anything

"Custom Weight Paint Range" is off

EDIT: Minimal Working Example In weight paint mode with Viewpoint Shading set to solid, this mesh will look all grey instead of showing the weights.

enter image description here

$\endgroup$
  • $\begingroup$ You'll only see weights in solid shading mode, I recommend that you upload your .blend file. This will go quicker for you to get an answer. $\endgroup$ – Yvain Sep 22 '18 at 10:36
  • $\begingroup$ @Yvain see edit $\endgroup$ – User1291 Sep 22 '18 at 14:37
  • $\begingroup$ For the sake of protocol, can you make a new blender file, anything really, just try to weight paint the default cube for example. If you don't get the colors then you have something wrong with you blender installation. $\endgroup$ – Yvain Sep 22 '18 at 16:37
  • $\begingroup$ @Yvain just tried. weight painting the default cube works as it should. $\endgroup$ – User1291 Sep 22 '18 at 16:44
  • $\begingroup$ Okay, you can dismiss the concern of having a broken install. $\endgroup$ – Yvain Sep 22 '18 at 18:04
0
$\begingroup$

Ok, I think I have this figured out...

If I set the viewpoint shading mode to solid and THEN enter weight pain mode, the weights are being displayed.

However, if I enter weight paint mode first and THEN set the viewpoint shading mode to "solid", everything is shown grey, instead.

So the easiest way to solve this grey stuff is switching to object mode and back into weight paint mode.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.