0
$\begingroup$

enter image description here

As you can see the texture shows up on all objects except this one. What’s wrong?

$\endgroup$
3
  • $\begingroup$ In object properties, Under viewport display, is the Display As set to textured for that object? $\endgroup$ Nov 1, 2023 at 15:20
  • $\begingroup$ Presumably it (and the rivets) are seperate objects so if they don't have a material applied to them they will just show the default colour. $\endgroup$
    – John Eason
    Nov 1, 2023 at 15:20
  • $\begingroup$ Sorry, without seeing the material you have put on the object and/or the display settings etc. we can only guess. $\endgroup$ Nov 1, 2023 at 15:22

2 Answers 2

1
$\begingroup$

I guess you refer to the Solid Viewport Shading with Texture Color setting?

enter image description here

In this mode, the display is affected by the last selected texture node.

It if it is an Image or Movie texture node, it shows that. But if it is any other texture or haven't ever selected anything, it instead shows the Material's Viewport Display options:

enter image description here

$\endgroup$
1
$\begingroup$

Solved, under viewport display it was set as solid and not textured. Not sure why the other objects automatically switched over to textured, though.

$\endgroup$
1
  • 1
    $\begingroup$ This might not have been your problem, but my explanations in this answer regarding how the Texture mode in solid shading works might give some insights: UV grid appearing as solid colour because even if set to Textured, in other viewport shading modes there can still be differences. $\endgroup$ Nov 1, 2023 at 18:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .