1
$\begingroup$

I have a simple plane which I have unwrapped to match a picture, so it's just a picture as a plane object. When I selected "textured" in the viewport shading, I could clearly see the picture projected on the plane. But suddenly, the texture/picture didn't show up, and when I select "textured" I only see a gray plane...

enter image description here

As you can see, the plane is wrapped to fit the picture, and the 3D view is set to "textured", yet the picture doesn't show up like it used to. Help!

EDIT: The picture doesn't show up on render view, either, making it a more serious problem I guess.

$\endgroup$
  • 1
    $\begingroup$ Cycles? BI? Which render engine are u using? $\endgroup$ – Unnamed Sentient Being Dec 26 '16 at 23:22
  • $\begingroup$ Related - blender.stackexchange.com/questions/5283/…. If the picture isn't shown in the rendered mode then probably material isn't set up as needed. $\endgroup$ – Mr Zak Dec 26 '16 at 23:24
  • $\begingroup$ I just thought of this. It seems like it works on blender render but not blender cycles. How could I make it work on cycles, though? I'm guessing I have to add a material and use the UV-coordinates to project the picture... imma try that out now. $\endgroup$ – Espen Sales Dec 26 '16 at 23:24
  • $\begingroup$ Ah, it apparently works if I simply add an image texture and select the picture from the list. $\endgroup$ – Espen Sales Dec 26 '16 at 23:28
1
$\begingroup$

Found the answer:

When using Blender Render, you only need to UV unwrap an object and add a picture to make it show up in texture viewport. When using Cycles, you need to do as in BR and then add a material, go to node editor and add an image texture. Select the picture you UV unwrapped the object to, and without connecting the node anywhere, the texture shows up in viewport texture mode.

$\endgroup$
  • $\begingroup$ Just to be clear, this is the correct answer, just that I cannot accept it as such before two days have passed. Happy Blending! $\endgroup$ – Espen Sales Dec 26 '16 at 23:33
  • 1
    $\begingroup$ This solution is also an example of best practice - always load the image into the material texture slot, even if Blender Render migth allow you not to. Also, when using image textures, sometimes the easiest way to handle them is to enable the Add Images as Planes addon that ships with Bender, and then you can be sure the image will come in already mapped to the correct aspect ratio. $\endgroup$ – Craig D Jones Jan 26 '17 at 0:05
1
$\begingroup$

Try looking at the Object tab on the properties bar (the little box) and then go down to the "display" tab and look for the "Maximum Draw Type" set to "textured", you will have a choice of wire, solid, textured and bounds.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.