0
$\begingroup$

I can't see the textures I assigned to my material on my object in the 3d view port in texture mode. However I can see them in render mode. Why can't I see them in texture mode so I might be able to edit them better without the lag of trying to do it in render mode? I also think this is the same reason why I can't bake the textures that I've applied to the materials on the object to a separate texture for exporting and importing purposes. I've searched all over the internet and it's a common problem, however none of the solutions have worked for me. I've tried switching between cycles and blender render. In the shading options I've tried both multitexture and GLSL shading with all the different options. I've tried opening the image to the UV editor and manipulating the unwrapped projections to see if they show in texture mode. All of these thing's I've saw in render mode but I can't in texture mode. Also, it's not how I unwrap object either because I've done this with just a simple cube (easy unwrap). I've even gone as far as thinking there was a bug in the program, uninstalled in and reinstalled it and I still can't see textures in texture mode. I'm asking please, If anyone has some insight that may help me, please let me know. I've added a picture to help illustrate my problem. Thank you. Left 3d viewport in texture mode, top right is 3d view port in render mode, bottom right is the unwrap

$\endgroup$
  • $\begingroup$ Did you try also opening the texture in the uv-image-editor? $\endgroup$ – schustudrai Mar 27 '16 at 7:33
  • $\begingroup$ I did, the image will show in the uv editor with the unwrapped pieces, however the texture will not show in the view port in texture mode, it will only show in render mode. $\endgroup$ – Robert Parsons Mar 27 '16 at 18:13
  • $\begingroup$ pasteall.org/blend/41252 here is the cube, packed blend file with texture $\endgroup$ – Robert Parsons Mar 27 '16 at 18:14
  • $\begingroup$ I have downloaded your File. For me the textured mode works fine. $\endgroup$ – schustudrai Mar 27 '16 at 19:16
  • $\begingroup$ That's weird it's not working for me. Thanks anyway, really appreciate your help. $\endgroup$ – Robert Parsons Mar 28 '16 at 3:00
1
$\begingroup$

Yes schustudrai said it you must link your image with the button here:

enter image description here

$\endgroup$
  • $\begingroup$ I've done this and it's still not showing in view port. pasteall.org/blend/41252 is the packed blend file with the texture. $\endgroup$ – Robert Parsons Mar 27 '16 at 18:15
  • $\begingroup$ I opened your file and your cube was shaded with the texture in 'texture mode', I didn't have to do anything for it to work, but your image was still not linked I gues you did'nt go into edit mode and select all faces before selecting the picture in the drop-down menu. $\endgroup$ – Yvain Mar 27 '16 at 20:27
  • $\begingroup$ Yea, I've done that as well. It's weird it's not working for me, idk what else to try. Thanks for your help anyway! $\endgroup$ – Robert Parsons Mar 28 '16 at 3:01
0
$\begingroup$

I've had odd issues like this when I was using Blender to make a 3D presentation - except that all textures were working in Blender Render, and in Blender Game, some textures just didn't work - and what was displayed in the editor was an entirely different story. I spent hours trying to figure it out, even compared every last detail of two objects where only one of them was working, only to find no difference. I ended up just creating a new blender file and copy-pasting everything into there, and it somehow suddenly worked.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.