2
$\begingroup$

I can't seem to delete unwanted tracks when I have the "Include Missing NLA" button selected. What bothers me more is it seems to create tracks by random. In the screen shot below, 1/4 lights have an NLA track, my camera has an NLA track, the Mesh Body that is attached to my Armature has an NLA track and the armature itself has an NLA track. Also the eyeballs have one. This seems very random, where do these tracks come from? Why are they so random? Is it possible to clean them up?

enter image description here

$\endgroup$

1 Answer 1

1
$\begingroup$

You must have given an action to these objects at one point. But to remove all the useless tracks, right click and Remove Empty Animation Data:

enter image description here

You can also activate the Only Show Selected option, which will allow you to only see the track of the selected object(s):

enter image description here

$\endgroup$
2
  • $\begingroup$ This method doesn't work. It literally empties the animation data, but the "eyeball" and the "Body" objects with empty tracks are still there. $\endgroup$
    – Jimmy Lin
    May 26, 2023 at 11:09
  • $\begingroup$ Please share your file (remove all the useless objects): blend-exchange.com $\endgroup$
    – moonboots
    May 26, 2023 at 11:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .