0
$\begingroup$

I have been having a problem recently (could it be 2.83?) whereby the animations are not showing the selected armature.

Initially they do show but as I work more and more, the editor will only show the selected bones, until finally none of them will show. Also if the NLA is used at all, it's very difficult to get the dope sheet and the graph editor to show again. Usually by switching to and from various bone groups after selecting the animation icon in the Scene Collection.

How do you get the graph editor back after using the NLA? I have attached the Blend file and a screen shot showing the selected elements resolutely refusing to show in the dope sheet. My work around atm is to export an FBX and reimport it into a fresh Blend file.

Blend file not showing animation

Animation not showing

$\endgroup$
0
$\begingroup$

I don't see any problem with your file but I'm not playing it with the latest version.

For the moment the armature is playing the animation that you've pushed down into the NLA editor. To see or edit this action you can select the strip and press Tab, the strip will turn green and the keyframes will be displayed in the Dope Sheet.

enter image description here

If you want to load any other action, switch the Dope Sheet to its Action Editor mode and choose whatever action you want in the dropdown menu (now the Dope Sheet will play over the NLA, to come back to the NLA actions you'll need to close the actions you've opened in the Dope Sheet).

enter image description here

To switch directly from Dope Sheet to the Graph Editor you can press CtrlTab.

Also, the Only Include options may be useful sometimes to only see the keyframes of the selected bone(s) but don't forget to disable it if necessary:

enter image description here

| improve this answer | |
$\endgroup$
  • $\begingroup$ LEGEND!! God I have been tearing my hair....The arrow at the end was the key. I followed your instructions and got my dope sheet back...the one I had set up to make the screenshot. But the lower dope sheet still did not show...it was "only include" option I had switched on that prevented me from seeing it. $\endgroup$ – DrIgnatiusCole Jun 7 at 15:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.