enter image description here

Having a new issue with Dikko's arm rig tutorial at around the 31:00 marker.

I'm wondering if this stretching and pulling is due to the placement of the subdivision in conjunction with the mesh's edges?

The bone parenting matches Dikko's in my rig and my IK arm tests functioned just fine until this point in the tutorial.

The only issues I could think of to check were bone parents and maybe my mesh not being dense enough.

The arm does not bend in this way of course. Dikko's testing to see if the reskin took hold of the subdivided bones.

But I still feel as though this stretching is abnormal even at this stage.

Any idea what I might have done wrong?

Linked in my google folder is the "error" mesh.


2 Answers 2


EDIT: I was hasty in my earlier answer. Here is what I tried that appears to have fixed it:

  • Exit Pose Mode

  • Select the model in object mode.

  • In the Properties editor Object Properties tab, open the Relations panel and click the 'x' in the Parent box to delete the Armature as parent

    Relations panel showing the delete button for the parent

  • In the Properties editor Modifiers tab, find the Armature modifier and click the x to delete it

    Modifiers Panel showing delete button on Armature modifier

  • Shift–select the armature

  • Type CtrlP to parent and select with automatic weights

    Parent menu showing automatic weights highlighted

This seems to have solved the problem. I don't know what you'd done wrong before, but the hand moves fine now.

  • $\begingroup$ Thanks! This begs a new question, however. My original mesh ( 1 RICK TOPO ) has bone heat issues documented on my CG Boost thread. I used a transfer method with a duplicate mesh in the “DUPE 2” collection to circumvent this. Dikko’s tutorial mesh lacks weight paints for the arms too. The forearm is dark blue. So why is mine acting differently? Is it because the wrist of my mesh is actually connected to the forearm whereas his is not? Either way, I’ll try your method and let you know if it resolves itself. : D $\endgroup$
    – Mulder
    Commented Jan 24, 2022 at 2:04
  • $\begingroup$ <<< Response Index Resources >>> My CG Boost Heat Map Post: bit.ly/3rIFxTp … Dikko’s Gumroad Ragnar Rig: bit.ly/3qU2UtL … Bone Heat Map Tutorial I Used: bit.ly/3GXZOuj $\endgroup$
    – Mulder
    Commented Jan 24, 2022 at 2:07
  • $\begingroup$ I tried your example but it sadly did not work. :( Just to reiterate, Dikko's arm rig does not have weight paints at this stage in the tutorial either. Maybe there's a bug with my "bone to mesh" parenting since I'm using the duplication troubleshooting method, but either way, my error as posted still exists. Thanks for attempting to help me however! $\endgroup$
    – Mulder
    Commented Jan 24, 2022 at 2:18
  • $\begingroup$ @Mulder Turns out reparenting fixed it. See my edited answer. $\endgroup$ Commented Jan 24, 2022 at 2:47
  • $\begingroup$ Omg thanks so much; this worked! You're a GOAT. 🙏🏆 ... 📌 I also want to note for any newbies like me: I thought Marty's fix somehow erased my bone layers. It did not! I simply had protected layers enabled which did not allow me to shift and move around my layers. Make sure you disable this to move around! $\endgroup$
    – Mulder
    Commented Jan 25, 2022 at 4:44

While Marty's method was very informative and helpful ( again thank you! ) I figured out what I truly did wrong on further inspection and the fix was far easier.

My subdivided bone ( DEF_forearm.L.002 ) connecting directly to the wrist had the "deform" option turned off ( within "bone properties" ). Enabling that fixed the issue.

The best advice I can give is really look at the tutorial and see if anything is enabled or disabled that should not be on your end!

Newbie user error! 😅


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .