6
$\begingroup$

I have created an object and I have assigned a bunch of materials, each with different diffuse colors (for use in dDo) to different parts of the model. What I can't figure out is why when I bake my Ambient Occlusion map I am getting color information in my AO Map. Clear is the only item that I have checked in the Bake Settings. I am also getting the same behavior when I export my UV layout. I don't think I have ever seen this before and I am totally stumped. I don't have any vertex colors on the model. I have no textures in the scene either as I removed them by holding down Shift and unlinking the datablock for my texture bakes. I have cleared all those out and restarted Blender. All I have is my model and a whole bunch of materials with different diffuse colors, that I have assigned to different parts of the mesh. What would be causing such a thing to happen?

enter image description here

enter image description here

$\endgroup$
5
$\begingroup$

In BI the diffuse color is used to color AO output.

One way to avoid this is to enable Normalized in the bake settings:

enter image description here

$\endgroup$
  • $\begingroup$ Thank you! That definitely solved the AO map problem having color information. I am still continuing to look for a solution to eliminate color information for the UV Layout map since I know of no way to alter settings there. $\endgroup$ – Bryson Jack Dec 21 '14 at 23:24
  • $\begingroup$ @BrysonJack Hm.. I can't think of anything besides I quick python script to set all the diffuse colors to white (either running on a backup .blend or storing the values in an array for setting them back later). If that's not acceptable, does desaturating the UV map work well enough? $\endgroup$ – gandalf3 Dec 22 '14 at 0:56
  • $\begingroup$ Well, if Blender isn't misbehaving, or I didn't accidentally change a setting somewhere and that is the normal behavior then I will have to come up with some kind of workaround. I really appreciate your help gandalf3. $\endgroup$ – Bryson Jack Dec 22 '14 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.