1
$\begingroup$

I'm getting strange noise regions on baked ambient occlusion maps. I've tried to change number of light bounces, noise threshold and number of samples but nothing works. Despite the different settings, these regions remain the same.

I don't use subdivision subsurface modifier and the geometry of my mesh is quite simple so it's not connected to triangles. They appear not only in dark areas, so it seems like it's not connected to light bounces at all. The edges of these noise regions are not smooth and have a strange shape.

Is there any way I can get rid of it?

Screenshot

Screenshot

$\endgroup$
8
  • $\begingroup$ Hi, a0405u ... I think it would help, here, to share your file on blend-exchange.com, following the instructions there, and pasting the link into your question. $\endgroup$
    – Robin Betts
    Jul 1, 2023 at 6:57
  • 1
    $\begingroup$ I've added a .blend file! $\endgroup$
    – a0405u
    Jul 1, 2023 at 7:15
  • $\begingroup$ I can't reproduce this effect on the pieces I have... I was looking for the chunk in your illustration.. could you rejig your share to isolate that failing bit, exactly? Set up a shot so it's easy to find? $\endgroup$
    – Robin Betts
    Jul 1, 2023 at 7:44
  • $\begingroup$ Updated the file, so the area is visible both on AOMap and Viewport at startup on Shading tab. $\endgroup$
    – a0405u
    Jul 1, 2023 at 18:28
  • $\begingroup$ Thanks for the update.. still can't reproduce, which suggests graphics card? There is one thing I noticed, which I hadn't realized before.. at least, on my system, AO does not probe objects outside screen-space, so tracking in and out changes the shading. Your effect feels like a de-noising artefact, to me, but that's just a guess, based on the look of it. $\endgroup$
    – Robin Betts
    Jul 2, 2023 at 5:43

1 Answer 1

2
$\begingroup$

Ok, it's related to Adaptive Sampler Noise Threshold, and seems like a bug. Disabling it or changing the threshold to extremly small values fixed the issue. Noise level on bake doesn't look like the level I set. The difference between pixels on the noise regions of the refence images is a lot bigger than 0.001. It works a lot better on older versions like 2.9. I'm creating bug report at developers portal.

$\endgroup$
3
  • 1
    $\begingroup$ I'm not sure if it is a bug per se (noise threshold is, after all, choosing an acceptable amount of noise), but I was able to reproduce your issue in 3.6 on my GTX 3080. Disabling or mitigating the noise threshold seemed to work. $\endgroup$
    – Kirbinator
    Jul 2, 2023 at 23:46
  • $\begingroup$ Glad you found it! $\endgroup$
    – Robin Betts
    Jul 3, 2023 at 6:28
  • $\begingroup$ It is definitely a bug, because the noise level is inconsistent and it appears only on ambient occlusion maps, and not on any kind of light maps. The noise level on light maps with enabled Noise Threshold seems similar to the noise level on the "not noisy regions" of the ambient occlusion map. So it is probably something that changes the noise threshold on some regions when baking ambient occlusion maps. $\endgroup$
    – a0405u
    Jul 4, 2023 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .