I have been experiencing quite a few problems with the rendered view. As you can see in the video, for some reason the camera view is flipped/reversed and I don't know why it has done this. Like I have the object rotated to the left and in the rendered view its to the right which is confusing. Not only this but whenever I go out of the render view and try to move around the object it rotates around the z axis but flipped on it's side.

I'm also facing problems with the rendered view, I am using a HDRI environment and the spot light I have added doesn't light up my object. Also I want the background to show as black whilst the render is still using the HDRI to light the object but it just appears as a grey background.


If someone could help me that would be amazing! thanks,



1 Answer 1


Somehow, your camera is showing a negative scale transform.

I would:

  • Swipe the camera's 'Scale' fields in the Item tab and set to 1.
  • Readjust the camera using its internal settings (Focal length, or Lock Camera to View, etc)..

Maybe even swipe the padlocks next to the camera's scale to lock it off. You need special reasons to alter it.

  • $\begingroup$ thanks this helped a lot! do you know why my background isnt appearing black? also why the spot light isnt working? the current render shows the hdri when I want it as a black background. i.imgur.com/nVIKI9z.png $\endgroup$ Oct 26, 2020 at 12:24
  • $\begingroup$ Is your preview set to use 'Scene World', and 'Scene Lights'? (Header > Material Preview > (Down Chevron on the right) Viewport Shading) $\endgroup$
    – Robin Betts
    Oct 26, 2020 at 12:27
  • $\begingroup$ Yeah I had them sleected. I want to somehow use the mattcap hdri and use a black background for the scene is this possible? Would I use a background shader on the world and then select a mattcap for lighting the scene? $\endgroup$ Oct 26, 2020 at 12:42
  • $\begingroup$ Got it working the only thing I can't seem to get to work is the area light that I want to be shining onto the object. As you can see it is there on the viewport but no light is being emmited from the light. Is there some setting that toggles the view of lighting in the viewport and render. As it doesn't appear in the render either. i.imgur.com/KOweEJC.png i.imgur.com/NJxYBR0.png $\endgroup$ Oct 26, 2020 at 18:15
  • 1
    $\begingroup$ So this is how the two objects are shaded. The solid with a principled shader, metallic with no roughness and the lines are an emission shader in pink as shown in these examples. The area light is green and large enough to cover the object its targetted at. i.imgur.com/yAjpnZi.png i.imgur.com/ED5LmsR.png i.imgur.com/HDZLX3s.png $\endgroup$ Oct 26, 2020 at 18:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .